Mantis to Mattermost webhook plugin problems

Hy all,

First of all, im not a coder myself thats why i came here for help.

What i want to do is send statusupdates from Mantis to a Mattermost channel.
Since that “should” work with Slack i found a nice plugin that can send those alerts to Slack (and confirmed it works).
Figuring i only had to change the webhook url to that of my mattermost but sadly that trows a curl error and no way of telling (for me) what causes that error.

The error:
The request to Slack didn’t go through. Check your webhook URL. Also make sure there are no unusual characters in your bot name or bot icon settings. Further details may be printed below this box.
Please use the “Back” button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.

Can somebody help me out “porting” this plugin so it can work with Mattermost?

The plugin in question is:

I have the feeling its “simple” but since im no coder this goes above my knowledge.
Thanks in advance!

Can you provide a screenshot of the configuration that you set up for the plugin?

From the Mantis or Mattermost?

Ideally, both. I can’t provide support for Mantis, but I can take a look at your two configs and see if anything looks obviously incorrect.

Thanks for looking into this.
Mind that im not a IT guru :wink:

If i setup the mantis plugin with a webhook for Slack, it works.
If i send a httprequest manual from terminal using the webhook for mattermost that works fine.
But if i use that same webhookurl for mattermost, mattermost trows an error.

Im not at pc right now but wil send you config and further details today or tomorrow.
Thanks in advance

Hey @bafplus any new developments on this issue?

Hy, sorry for the late reply.

Wo dont have any succes yet.
It seems it fails on a empty value in the string.
We however cant seem to pinpoint where that is generated.



Unfortunately, I’m still going to need to see your Mattermost/Mantis config in order to help. All I can tell from those snippets that you provided is that you’ve got a dash in some config value that’s expected to be a number.

The link to the plugin is in the main text.


@bafplus I’m afraid you’re going to have to give me some more context here. Where did you see the error you posted above? Where is this screen shot from? It doesn’t look like a tool that I’m familiar with, so I’m having a difficult time diagnosing the problem.

In the original error message that you posted, this text appeared: “Also make sure there are no unusual characters in your bot name or bot icon settings”. In the subsequent error messages that you posted, the logs were complaining about a dash character (-) in something that was expected to be a number. I would suggest that you check all of the configuration for dash characters, and see if there are any in unexpected places that could be removed.

The problem is that UID= part. Its empty and because of that thereś a - in the string. However…i cant seem to find WHERE to input that UID. Its not in any of the configs.

I’m afraid that I don’t know enough about Mantis or how it is configured to help you.

Is there anyone in the community who might be able to help @bafplus troubleshoot his issue?

I have created a plugin for the integration, basically I took the code of Slack + Mantis Plugin and changed it to Mattermost, so far it is working fine for me.

I have just encountered error of special characters in the description/title and will solve that very soon.

Would require feedback on the plugin too

Fantastic @aalasolutions! Thank you :slight_smile:

Would you be open to sharing your work? If so, please complete this form where you’ll be able to follow progress in the Integrations and Apps channel on our nightly build server.

Thanks again for your work on this integration!

@lindy65 Thank you, i have filled the form and also joined pre release channel

I see the details of your integration in the channel @aalasolutions - thank you!