Mattermost no longer reachable from PC

This morning our server was no longer reachable. I searched for the reason, but the error messages when trying to start Mattermost were not helpful. At last, I found out that Ubuntu ran out of disk space and the config file for Mattermost was empty?! I made room on the drive and replaced the config file with a backup. And I changed mattermost.service to use the binary “mattermost” instead of “platform”.

Mattermost now starts without errors, but sends no data. The web browser window stays empty.
This is true for all Windows PCs. Then I tried it with my Samsung Galaxy S10+ - and it works!

I have no idea where to look for this error.


If found this in the log:
{“level”:“error”,“ts”:1601285465.3624492,“caller”:“http/h2_bundle.go:4218”,“msg”:“http2: server connection error from : connection error: PROTOCOL_ERROR”,“source”:“httpserver”}

We fixed it somehow, but my colleague is not really sure how. He is responsible for our firewalls and just did one thing: create a filter for a log. As soon as he removed the filter, everything went back to normal.
This should not happen, and it cost me 5 hours debugging and searching. I even updated Mattermost Server. So if anyone else is coming across this problem, consider your firewalls.

1 Like

Hi @VincentVegas - thanks, we have this same error as well and I’ve been scratching my head over it. In fact our server log is littered with these PROTOCOL_ERRORs from all different clients. Oddly, its not causing any issues for any users but its very bothersome.

Are you able to provide any more details on the firewall filter you set up / changed?