Omnibus installer broken in 8.6.0?


I recently upgrade from 8.4.x to 8.6.0 of an installation which disabled gitlab and only runs mattermost via HTTP on port 8065 on CentOS 6.5. After upgrading with yum to 8.6.0 mattermost wasn’t responding on port 8065 despite I could see mattermost running on that box and saw that it responsed to

Poking around a bit I found that gitlab was active on port 80 (it shouldn’t be there) and in /var/opt/gitlab/nginx/conf there were two configs, one for gitlab on port 80 and mattermost also on port 80. Changing mattermost to port 8065 and run gitlab-ctl restart nginx it worked again.

So with this working I tried to enable SSL for mattermost. All changes I make to mattermost[…] variables in /etc/gitlab/gitlab.rb gets ignored.

That wasn’t the case in 8.4.x.

Should I wait for 8.6.1 or can I do something by my own?

In Nginx configuration, two virtual hosts can coexist on the same port. This should not be a problem. It’s possible there is a bug in Mattermost GitLab packaging in 8.6.0 but I haven’t heard anything yet. Did you try sudo gitlab-ctl reconfigure and sudo gitlab-ctl restart to ensure everything was successfully upgraded?

@dblessing Yes. I’ve only edited /etc/gitlab/gitlab.rb and then did the gitlab-ctl dance. Notably the external_url was honored, but more or less nothing else.

Can you point me to the bugtracker and the source of the chef cookbook? Or is this forum everything where I can troubleshoot my issue?

@dblessing And on the subject of two virtual host on the same port: How is this handled? Despite that I disabled gitlab on that host reaching out to port 80 presents the gitlab login. So if both, gitlab and mattermost, is active on port 80 - do I have to differentiate by path name then? If so, the nginx mattermost config does not do this, it proxies all request to / to the internal mattermost server on