Outgoing webhook fails with i/o timeout


trying to setup the Giphy integration we’re stuck with the outgoing webhook. It never reaches the python server and fails with i/o timeout.

Steps to reproduce

Mattermost 4.3
Giphy integration
Using slash command to trigger the webhook

We’ve checked firewall and everything is ok, the problem is not there.
We’ve sent a POST directly to the phyton server and it responds ok, so the problem is not in the server.

Looks like Mattermost can’t send external webhooks but is not a firewall problem.
We’ve check the config.json from top to bottom without sucess.

Any ideas?

Thanks !!

The IP where we send the webhooks is a local IP … … just is case that helps

Solved !!!
You need to add the IP where the python server is listening to the config.json

"AllowedUntrustedInternalConnections": "",

With that it works !!

@richilp Awesome, glad to see you solved it. We don’t allow connections within the local network by default, otherwise an attacker with the ability to create integrations could use it to bypass your firewall and access other machines in your network (obviously not good). We should probably document this better though since it is a totally valid use case to allow that, and I know other people have had the same issue.

1 Like