Push Notifications Not Triggering

Brand new fresh install of Mattermost to test out and while everything else appears to be working correctly, push notifications don’t.

Server Summary

Ubuntu 20.04.1 LTS
MySQL 8.0.22
Mattermost Version: 5.30.1
Database Schema Version: 5.30.0
Database: mysql

Breakdown of issue

Push notifications don’t work. Running log at debug level and not getting anything in the log related to push notifications. Have verified that it’s enabled and currently set to use Mattermost’s test push service. Have tried disabling, restarting service, reenabling, restarting service, etc to see if something is a stuck with no success.

Even after enabling “For all activity” and “Online, away or offline” for the test users no activity will trigger a push notification.

Don’t know what else to check at this point. Any assistance is greatly appreciated.

Hello @ca2kjet, I’m sorry to hear that you’re having trouble, but I’m confident that we can get this issue resolved!

Can I ask if you have noticed any errors in your MySQL logs, or your Apache/Nginx proxy logs?

I checked both the MySQL log and Apache log and no errors. I did a query log but couldn’t spot anything. I don’t know exactly where the push happens on the programming side of things. It’s strange, I feel like I’m missing something but the install and setup was a breeze so not sure what else to do. Would running on ports that aren’t 80 or 443 (currently using 8065) cause this issue?

It shouldn’t, I don’t think unless you have improperly configured your reverse proxy.
Could you elaborate further on your installation, and what type of reverse proxy you are using, if you are, as well as the configuration for it?

No reverse proxy in use. I followed the install guide from here; Installing Mattermost on Ubuntu 20.04 LTS — Mattermost 5.30 documentation

1 Like

I think that may be a contributing factor to the issues your experiencing then, because It would then appear that you skipped part of the setup, I linked directly the section of the above documentation so that you can check it out and verify if you indeed didn’t do this part of the setup or not. Here’s the link:

Hello, @ca2kjet

Besides the proxy setup of Mattermost Server shared by @XxLilBoPeepsxX , I would like to confirm if the push notification is broken in general. When you attempted the push notification test, did it go through?

Are you using the default push notification server or rather a hosted one?

The support team is investigating a potential issue with push notifications happening on 1.38 mobile app as well. Can you confirm if you are running on the same version too?

1 Like

@XxLilBoPeepsxX My understanding is a reserve proxy is an optional, more expanded, setup for the server itself. To me it just adds more complication to the test setup that I’d prefer not to use. Is a reverse proxy required for the push notifications to work?

@ahmaddanial I have it set to use the default https://push-test.mattermost.com It’s really strange because I never see anything in the console server logs related to “push” and I’ve got it set to debug mode. I do have the push notifications enabled in the config. When I do a test it comes through no problem every time. The app I’m using is 1.38.1 for Android. Do test pushes originate from the phone app or come through the server?

We have a ticket open to investigate push notification issues that could be related to this: https://mattermost.atlassian.net/browse/MM-31873.


I have exactly the same problem, and i would like to know if there was any news from this issue since January 2021 ?

Hi tasseb,

what is your push server set to in the configuration settings and does the push notification test work for you as described above?

What deployment model are you using? Docker? Kubernetes? Gitlab? Binary? When you are on the shell where your mattermost application runs (inside a container or directly on your sever), does the following command return the same result for you?

# curl https://push-test.mattermost.com
<html><body>Mattermost Push Proxy</body></html>
1 Like

Hi, thank you for your help, everything has been resolved. It was a network issue, so nothing with the mattermost configuration.
I had 2 default routes after an update. So I had to remove one of them and the push notification worked after that.

Awesome, thanks for the reply, glad to hear it’s working for you now!

1 Like