Push notifications not working


I am using the Enterprise Edition of Mattermost but we don’t have the E10 licence until we know it will work for us. Version is 3.10.0 and the Database is Postgres (Doubt it will make a difference… but)…

We have it running on a box on our internal network. Using TLS and running on port 8065. There is no proxy in between. The SSL certificate is issued by LetsEncrypt.

On the Android client side (using Android Nougat) I have tried 3 of the main clients available in the store (Mattermost, Mattermost Classic and Mattermost Beta 2017). The same issue seems to affect every client.

Everything else seems to work, internal and external users can chat to each other, messages seem to appear immediately if in the correct channel/DM. Users can see if others are typing but haven’t sent the message yet.

Email alerts of mentions work. The only thing that doesn’t work is the push notifications.

Settings are:
Enable Push Notifications: Use iOS and Android apps on iTunes and Google Play with TPNS
Push Notification Server: htttp://push-test.mattermost.com
Push Notification Contents: Send generic description with user and Channel names

When a user in the desktop client sends a DM or mentions a mobile users the log shows:
[EROR] Device push reported as error for UserId=5qx6jmqjif89pkej9dwte61w4y SessionId=4fj3d5a5i3nftnpoqtmfzqmpde message=Post http://push-test.mattermost.com/api/v1/send_push: dial tcp: i/o timeout

Any help with this? If we can’t get push notifications working then Im afraid mattermost is no good for us.

Thanks in advance,


One question here would be: can your server reach push-test.mattermost.com?


I can ping and curl -I from push-test.mattermost.com and it turns out that the errors are intermittent. Sometimes they work fine and sometimes they dont.

I have tried accessing the url directly in a browser (http://push-test.mattermost.com/api/v1/send_push and whether the push notifications are working or not, it always seems to return a 404 page not found.

The push-test system seems to be set up for testing and the documentation states:

Note: Mattermost, Inc. also offers a free basic hosted service for testing setups, Test Push Notification Service (TPNS), which is referenced in the Quick install for mobile apps via iTunes and Google Play instructions. It does not offer a production-level uptime expectation, nor does it offer encrypted transport.

I suspect the intermittent nature is related to the Testing nature and lack of SLA as a way to encourage moving to the E10 version, and that my server is configured correctly…

Thanks for your reply.


Hi @DanAndDusty,

Thanks for your feedback,

You’re correct that the push-test.mattermost.com is for testing purposes.

Chatting to our devs, they say it should work continuously, not intermittently.

Here are some docs that might help resolve the issue:

Is this helpful?