PUSH-PROXY: how can I turn on logging for the mm-push-proxy?

we have installed a Mattermost server and it is working fine. Push notifications are working also, including the iOS app using the test-push-proxy.
We did setup our own push-proxy now and re-compiled the iOS app with our own certificates, but we cannot get the push-proxy to work submit the messages. The process is running and answers on port 8066. Is there a way to turn on logging within the push-proxy? The MM log only says that it is has send the notification and does not report any error:

[2016/03/21 17:03:19 CET] [DEBG] Sending push notification to bd2eb7548b930c6b00d9b2b703923b1e2c685831c2b1def7756b59f7704be2d0 wi msg of ‘mmadmin mentioned you in Town Square’


Add. Info: there are 0 files in /logs, and wie have no idea why.

got the log info now.

And this is the problem we are facing:

2016/03/22 14:13:42 ERROR Failed to send apple push sid=tm4p8jbzd38rbnaba94brses7y did=c998fd0d699a757f139b2823a883334ae06996676ce9c33b7c6049237c24a199 err=crypto/tls: failed to parse certificate PEM data

Any suggestions?
We have installed the latest version of the Push-Proxy on an Ubuntu server

Looks like it failed to parse your cert files. Can you make sure they exist and are in the form of


"ApplePushCertPublic": "./config/publickey.cer",
"ApplePushCertPrivate": "./config/privatekey.pem",

Hi Corey
first of all, thanks for your reply.

I have tried what your suggested, but the error is still the same. I did also double check the permissions, files names, path and config-file and it looks all OK.

In the meantime I did verify the certificates, too, and I was able to connect to the Apple Push Server via openssl successfully (no errors):
openssl s_client -connect gateway.sandbox.push.apple.com:2195 -cert MY.cer -key MY.pem -CApath /etc/ssl/certs

… Verify return code: 0 (ok)

got it all working now. Removing the password from the private key did the trick.
openssl rsa -in pkey.pem -out newkey.pem
Which raises the question whether this is still a private key … anyway, problem solved.