RHEL / CentOS 8 Install issues

Hi All,
Today I spend my day trying to install the Linux version (non docker) on CentOS 8 (Stream).
Using the Installation Tutorial Provided here I progressed nicely, until I ran across subtle differences between CentOS 7 and CentOS 8.

Here are my notes that might save some others some headaches.

NOTE: I only tried to install the postgresql database not MySQL.

You don’t need to manually add the yum rpm files.

sudo yum install postgresql-server postgresql-contrib

Will install postgresql v10 just fine. You only need to adapt to a different installation directories.
sudo /usr/pgsql-9.4/bin/postgresql94-setup initdb will become sudo /usr/bin/postgresql-setup initdb
sudo systemctl enable postgresql-9.4 will become sudo systemctl enable postgresql

FirewallD appears to be enabled by default, so either disable it during intallation (and enable and config later) or add proper firewall rules. Helps when you receive failed to ping db errors.

When editing the systemcrl mattermost.service file note that the its called posgresql.service now.

If you receive mattermost.service: Failed at step EXEC spawning /opt/mattermost/bin/mattermost: Permission denied errors this is due to SELinux security preventing systemd launching the mattermost binary. I haven’t figured out how to manually add exception rules, but an easy fix it to set SELinux to permissive mode by editing


to SELINUX=permissive

You should be able to run mattermost now on RHEL / CentOS 8.

I tried installing nginx 1.14 (via yum install nginx), but it appears that the way the config files work have changed since the tutorial has been written. I managed to get re reverse proxy working but still get 502 errors. So I cannot help there.


1 Like

Hi wally4u,

Thanks for these updates! Could you create an issue for these changes in our docs Github repo? Then someone from our team or a community member can add them to the docs. If you’re feeling up to it you can contribute a change by following these steps.

1 Like