Role and Password changed during import

After importing my slack files, 2 things happened. 1. it downgraded my account from System Admin to team admin so I can no longer access the dashboard and 2. it changed my password but I’m not sure what it changed the password to. I assume it changed it to my slack password but I login to slack using my google login so I have no clue what it would have changed it to

Is there any way I can get back in and change my role or am I SOL? There wasn’t anything particularly important on there that can’t be recovered but I’d rather not have to start over again. I’m hosting it myself in a docker container on my Unraid server so I have access to the config files and such.
If I am SOL and just have to start over what can I do differently to make sure it doesn’t lock me out again? I am a team admin on the slack channel, what role would I need to have to ensure when importing mattermost doesn’t change me to a plain admin and keep me as a system admin?

It is a shame no one answered you quicker.

I just had the same exact issue and found a solution.

Here is how you need to do this:

  1. Setup your Mattermost container
  2. Create your initial user when you first login
  3. Create an additional super-admin user (with a username not used in your Slack accounts that you will be importing).

To do this use the mmctl tool from Mattermost.
Here are the two commands:
mmctl auth login https://yourmattermostinstance.com

mmctl user create --email whateveremail@whatever.com --username yournewusername --password thepasswordfortheuser --system-admin

  1. Setup Email Functionality in your Mattermost Instance
  2. Create a Mattermost workspace with an identical name to your old Slack workspace
  3. Import your Slack backup:

mmctl import upload your-exported-file-from-slack.zip

mmctl import list available
(note the new zip file name)

mmctl import process [inset the name from above step]

At this point your account is nerfed. Password changed and Privliges demoted… What a supreme messup on the part of Mattermost here… but I digress

Next step is to Login to your Mattermost instance with the second admin account you created above and fix everythins – i.e. give your nerfed account the correct access and reset the password.

ENJOY!

1 Like

Hi @jlar0che and thanks for providing this solution!

It’s also possible to use mmctl’s local mode to authenticate to the server without the need for credentials as admin account. To do that, the EnableLocalMode setting in config.json needs to be set to true and the server needs to be restarted. After that, you can use the command mmctl --local roles system-admin <username> to promote a user to admin or mmctl --local change-password <username> to change the password of the user in question.

2 Likes

@agriesser Thanks for replying! This helped us solve the same issue. We were a Mattermost Cloud Starter customer that got bumped to Cloud Free. We migrated to Mattermost on Kubernetes last month, which went just fine. We took the opportunity to import some old Slack corporate exports and got hit by this same problem.

For anyone looking in the future – in Mattermost on Kubernetes, the solution is the same overall. We added the following to the spec.mattermostEnvs in our manifest:

    - name: MM_SERVICESETTINGS_ENABLELOCALMODE
      value: "true"

Then exec’d into the pod and ran the mmctl --local roles system_admin [user] command and it worked.

1 Like