[SOLVED] Can't connect to mattermost from Zapier, Invalid client_id

My mattermost server version: 5.34.2
The integrations from Zapier to it used to work well until October 2022, then it stopped. Now I check back and try to set up again (by deleting all OAuth apps, restart mattermost server, add new OAuth app), but it keeps saying Invalid_client.
Here’s a video to what I tried

Any direction I need to look at, thanks.

(Don’t worry about me disclosing the secret credentials there, I’ll delete them)

Hi tommy and welcome to the Mattermost forums!

This sounds like an old issue I could find here:


According to this ticket, the problem also applies to you because it’s also sending temp as a client ID here (see this screenshot of your video):

Not sure how this works with the zapier connectors for Mattermost, but can you verify that your Zapier setup is using the newest build (or at least version 1.9.1 as mentioned in the ticket)?

1 Like

Hi @agriesser,
Thanks, I was able to fix by just changing the old Mattermost connection (1.9.0) to newest (1.9.1, figured out by the link to authenticate).