[SOLVED] Can't save config via System Console, after upgrade 2.1 to 3.0.3

I’ve just upgraded mattermost to 3.0.3 from 2.1

I can’t finalize step 6.2 from the team edition upgrade guide

Opening the System Console and saving a change will upgrade your config.json schema to the latest version using default values for any new settings added.

When I change something, the changes are not saved (I clicked on the blue save button).

If I change the config.json manually
let’s say I change:

“EnableDeveloper”: false,


“EnableDeveloper”: true,

The changes don’t appear on the System Console and the save button, gets greyed out.

Did you make sure to follow this version of the upgrade guide since you are upgrading from a 2.x release? https://docs.mattermost.com/administration/legacy-upgrade.html#upgrade-team-edition-to-3-0-x

Yes I’ve followed that tutorial. Sorry the link I’ve posted was the wrong one, so it was misleading.
As a matter of fact, I’ve added my comments to this guide in here

When you edit the config.json manually do you restart the mattermost service?

1 Like

for some reason, this feels like a permissions issue to me. do you run the MM server as root or do you have another account that it runs as? if it runs as another account, try doing a chown then chmod 755 to the mattermost server account on config.json.


@Sousapro Sorry for the late reply, you were right. A chown did the trick.

PS: I have no idea how to edit the title of my topic to add [SOLVED] in front

1 Like

Thanks a lot for the advice. Had exactly the same problem with our Bitnami Mattermost Team Edition Installation on AWS after upgrading to 4.3.1

Problem here was, that Bitnami’s upgrade Maunal (can be found here: https://docs.bitnami.com/aws/apps/mattermost/#how-to-upgrade-mattermost) includes this command after the upgrade is almost complete:
sudo chown -R root:root /opt/bitnami/apps/mattermost/server

After this, mattermost (which is also the system user who runs mattermost) could not change the config file.
With “sudo chown -c mattermost:mattermost /opt/bitnami/apps/mattermost/server/config/config.json” I could fix this issue.