[SOLVED] Can't access System Console after 2.2 to 3.0.3 upgrade

I was using a 2.2 version and only found out that I was quite behind on updates so I tried to follow the upgrade guide found in the documentation which told me to first upgrade to 3.0.3
This is what I did and I believe it went smoothly so I decided to do the next part, that is upgrading to the latest 3.X version (https://docs.mattermost.com/administration/legacy-upgrade.html#upgrade-team-edition-to-3-0-x)
In point 2, it says to go in the System console to check some settings. At first, I did not see the console, so I used this command to give me access to it:

./mattermost -assign_role -team_name="yourteam" -email="you@example.com" -role="system_admin"

And while I now see the System Console in mattermost, it stays “loading” on every item I click on.
Using developer tools, I find the following error:

method=getConfig msg=You do not have the appropriate permissions (system) detail=userId=mtw6st9z7pfu3gwtuyj8dzaxdh rid=98thrcfxdbg6b8pr8yaycidaua

I looked at the files in the installation folder, and sure enough, they were not for the right user, the tar command used those in the archive.
Using chgrp and chown fixed this, but it did not fix the original issue.

I looked here and found various topics on this subject:

But none of these helped me fix my issue.
I must have missed something obvious, but for the life of me, I’m not sure what it is.

Any help would be greatly appreciated.

I went looking for the error message itself in mattermost/platform repository files and could find it in the localization files, under the api.context.system_permissions.app_error identifier.
But when I look for this identifier, I can’t find it used anywhere in that repository, nor in the desktop one. I can’t even find system_permissions outside the localization files which is very strange to me.

I also tried setting the config.json rights to 755, 777 and back to 644 but nothing changed.

I’m really stuck here.

Hi @obones - it looks like for the other people who ran into this issue, the contents/format of the config file may have been causing the issue.

If you haven’t already, can you try using a config file like the default one for v3.0.3 to see if that fixes the issue?

Then you can change your config settings back to the way they were, either using System Console or by updating the config file with the values you want (just check the documentation to make sure the setting options are still named the same way as the old file).

Thanks for your answer.

I just tried using the default configuration file in which I copied the various values from the old one (database, email…) and I did not add any new key, nor did I change any value that looked to be default value (ie, empty string, null…)
After having restarted the service, I could still access my current content, but got the same error from the system console.

What I find weird is that I could not find a place in the source code that would trigger this error. Would you have any clues on that?

Also, I gave my account access to the console via the -assign-role command, could it be that this is not enough and I need to do something else?

Well, I finally managed to remember the default admin password and logged with it. Lo and Behold, it has access to the System Console!
So I went to user management, made my account a member then system admin again.
Once logged in as my account, I can now see the System Console as well.

So it seems I did something wrong with the console administration tool.

Thanks for your help.

Thanks for posting back your solution @obones,

It seems your issue is solved so I’ll close this off for now. If you have any further questions or issues, please feel free to post here again.