[SOLVED] New installation: Cannot access the system console

I’ve setup a mattermost instance following this guide: https://docs.mattermost.com/install/prod-docker.html

After installation, I’ve created an account using the web form, but my new user cannot access the system console - actually it couldn’t do anything before I created a team using the “platform” CLI tool.

So I tried to set the user’s role via:

docker exec -it mattermost-docker_app_1 platform roles system_admin username

However, that doesn’t do anything.

A similar problem has been discussed here: SOLVED - No system_admin - Can’t access system console
However, the proposed solution doesn’t work.

So, how can I access the system console to setup email and stuff? Or is this impossible unless I upgrade to the enterprise version?

I think I figured it out: I’m running mattermost behind an Apache and was not aware that the websockets had to be forwarded properly. After following the instructions here: https://docs.mattermost.com/install/config-ssl-http2-apache2.html?highlight=apache and enabling the necessary apache modules (look into your apache log if you have problems) it works now.