No system console access

I set up a mattermost server (5.10 on CentOS 6). Going to port 8065 everything seemed fine.

Then I went into the System Console and turned on TLS on port 443.

Restarted mattermost server process. I can still get in as a user, but my user can no longer see System Console.

In the database:

Roles: system_admin system_user

            Id: z5gh51ag8py1ddws8ks8e9dfwa
      CreateAt: 1556403620744
      UpdateAt: 1556588293632
      DeleteAt: 0
      Username: wwalker
      Password: $2a$10$REDACTED
         Email: REDACTED
 EmailVerified: 0
         Roles: system_admin system_user
AllowMarketing: 1
         Props: {}
   NotifyProps: {"channel":"true","comments":"never","desktop":"mention","desktop_sound":"true","email":"true","first_name":"false","mention_keys":"wwalker,@wwalker","push":"mention","push_status":"away"}

LastPasswordUpdate: 1556403620744
LastPictureUpdate: 0
FailedAttempts: 0
Locale: en
Timezone: {“automaticTimezone”:"",“manualTimezone”:"",“useAutomaticTimezone”:“true”}
MfaActive: 0

I tried creating another user:

sudo ./mattermost user create --email REDACTED --username guru --password REDACTED --system_admin

This user can also log in ; but, cannot see the System Console.

His roles:

Roles: system_user system_admin

Any ideas?

Thank you for your time!

Wayne Walker

Hi @wwalker,

Wondering if this previous thread might help:

Also, what is your SiteURL set to (

Hi Amy,

The config looks good, and works (as in the site works, just I get no SystemConsole)

I also get this:

Please check connection, Mattermost unreachable. If issue persists, ask administrator to check WebSocket port.

I’m using mattermost without a front end. mattermost is listening on 443, so all connections are direct.

Hi @wwalker,

Wondering if this troubleshooting doc might help: