Can´t get in admin_console webinterface anymore



I have Mattermost in Version 5.7.0 running in a Docker Container and my Internet Browser is Firefox. Normally I was able to open the admin webinterface with “http://mymattermostadress:myport/admin_console” . When I wanted now to open the admin webinterface, I got the Information my session was expired.
So far so good I logged in again, but from now I always get immediately redirected automatically from the “admin_console” URL to the Town Square Channel.

I tried so far:
Empty Webcache of Firefox and logging in again. Unfortunately I got the same resuld (got immediately redirected to townsquare channel).

Has anyone an idea how to solve this behaviour?

Best regards,


Steps to reproduce

My Session Exired (unsure if it could be the reason)?

Expected behavior

see summary

Observed behavior

see summary

Hi @Tim, these earlier threads might help:

Hello @amy.blais !:slight_smile:
I tried to set "AllowCorsFrom: “*” " in ServiceSettings of the mattermost_app container. Unforunately there was no change. In Console Inspector I got the output:
"Unhandled promise rejection TypeError: “NetworError whent attempting to fetch resource”.

In Chromium console I get a more specific error:
Get http://mattermostURL:Mattermostport/api/v4/config 403 (Forbidden)
Get http://mattermostURL:Mattermostport/api/v4/config/environment 403 (Forbidden)

Any idea how to solve this Problem?:slight_smile:

Ok, solved the problem: Seems the user I wanted to connect to the admin_console did not have the role to access the page.

Thank you for your answer!:slight_smile: