[Solved] Can't access System Console after upgrade


Been running 2.0.2 for a while. Upgraded today to 3.0.0 and then realised there was a 3.0.2 update. So upgraded as per the upgrade guide from 2.0.2 to 3.0.0 then subsequently to 3.0.2 http://docs.mattermost.com/administration/upgrade.html

However on both 3.0.0 and now 3.0.2 I cannot use the system console. I just get a “Loading …” in the middle of the screen.

In the mattermost logs I see nothing relating to my IP.

Any help would be appreciated.

System is running on a digital ocean droplet running Ubuntu 14.04 with nginx in front of mattermost. I have confirmed that nginx isn’t at fault by connecting directly to mattermost, and I see the same issue.

Also confirmed it’s not a browser issue as I’ve used Chrome and Firefox.

Hi @popey, could you please try:

  1. Restore your original database and Mattermost version just before the 3.0.0 upgrade
  2. Instead of upgrading to 3.0.0, try upgrading to 3.0.2 directly?
1 Like

Sorry for the delay getting back to you. I have rolled back to 2.0.2 and then gone directly to 3.0.2 and it worked perfectly.

Thanks for the prompt assistance!