[Solved] "Email and Password" Login Error - Only on iOS and Android

Hey folks! Just set up Mattermost on a DigitalOcean droplet via this tutorial. Currently running v8.1.0. Can login just fine via browser, macOS app, but when trying to log in via Android or iOS apps, we get an error “The email and password combination is incorrect” but of course, as we’ve checked many times, the credentials are the same as what lets us in via browser.

v8.1.0 for mattermost server, Android app version 2.12.2 (Build 6000506)

We have TLS set up with a LetsEncrypt cred we generated via the tutorial above. Happy to provide any sections of the config.json file needed!

Just an update, I’ve tried upgrading my Mattermost instance to v9.1.4, and unfortunately the error persists. Here are my settings for the “Web Server” section of my System Console. Using nginx as my server, as outlined in the tutorial in my previous post.

Given that I haven’t found many others with this issue, I suspect my configuration. The macOS desktop app allows logins, but given that it seems to be an Electron app, it’s probably handling things very similarly to the web login.

Do the iOS and Android apps manage login credential stuff differently? I have a feeling that’s the kernel of the issue.

I believe I’ve solved this, recording here for anyone that runs into this issue!

For some reason, the fact that I allowed new users to login with either their username or email seems to be the issue. I unchecked this setting in System Console, then created an account with a NEW email address, and was able to login with this new account on Android and iOS. The previous account made when the setting was not changed was still unable to login via app.

When I tried to delete my old account that wasn’t able to login, I was unable to. I tried using the mmctrl command line tool, but got a SQL error about the user ID not being found.

Not sure exactly how it got messed up, but that’s what worked for me!

1 Like