[Solved] Error message when trying to launch a Zoom videoconference


Non-admin user unable to launch a Zoom videoconference from the Zoom button.

Steps to reproduce

I’m on self-hosted Mattermost 4.5.0. I’ve successfully activated the Zoom plugin.
If a user different than me clicks on the Video icon, the following message appears:

“We could not verify your Mattermost account in Zoom. Please ensure that your Mattermost email address matches your Zoom email address.”

However, that user has registered on Zoom with the same email. Of course, this email is different than mine.

Expected behavior

I’d like to know how I can allow any user to launch a call (of course, provided that these users are registered on Zoom with the same email address used on Mattermost).

Thanks in advance.


Hi, @mcevoli,
I am having same issues with my MM 4.5.0, I haven’t tried this with admin account yet
can you tell me following things

  1. From which account you are currently able to do a zoom call – admin?
  2. if answer to above is yes, then is this admin account same for Zoom Dev Account?
  3. you are running zoom Dev as Free Trial or Subscribed Plan?
  4. from admin account are you able to start a meeting with other users?

Thanks & Regards

  1. I’m able to do a Zoom call from a Team Admin account, not a System Admin. However, the other user who can’t launch a Zoom call is also a Team Admin.
  2. My Team Admin account is the same for Zoom Dev Account.
  3. I’m running Zoom as Free Trial. I’ve registered a few days ago, so I suppose I’m still benefiting from their 30-day free trial
  4. I am able to start a meeting with other users from my Team Admin account. It works like this: a button appears on the chat and who wants to participate must click on the button, then they are redirected to Zoom app download (if they don’t have it already) so they can enter the Zoom call. I mean, the integration is just an embedded button, you don’t have the conference call inside Mattermost.

Best regards,

Hi @mcevoli @pankaj

Thanks for the feedback,

Not sure whether you’ve followed this documentation?

Also, v4.6 was released January 16th, so it might help to upgrade to the latest version of Mattermost.

Sure, I’ve followed the documentation step by step. In fact, Zoom works, but not all users can launch the calls. I’d like to know if others are experiencing the same, ie. if this is by default, or not.

Could you confirm if those users that are not able to call have their meeting ID correctly setup at their respective Share Zoom Meeting?

Also, if possible, let us know if upgrading to v4.6 helps solve your issue.


I’ve found out the cause of the issue. It doesn’t depend on Mattermost, or, better said, it’s a consequence of how the feature works.
Since the connection between Mattermost and Zoom uses one single account, the owner of this account must add all users to the Zoom Users section. This operation can be done only if you add a paying method to your account, although - apparently - you don’t need to have a paying plan to use it.

Once you add a user to the Account, then they will be able to launch a call from within Mattermost.

See screenshot: https://i.imgur.com/wisi4YO.png

And no, it was not related to 4.5 vs 4.6 version.

Cool, nice to see you solve the problem.

On our end, we’ll have it included on our documentation or feel free to submit if you wish to contribute at https://github.com/mattermost/docs.

Thanks for sharing!

PR to docs submitted. Feel free to comment, if any. Thanks!

Hi, I’m reopening this closed issue, because I also found out that you need a paying Zoom account to make it work. This is what the Zoom website says:

These management APIs are auto-enabled if you have a paid Zoom account. If you are a free basic user, we welcome you to subscribe for our 60 days free trial.

In fact, if I try to launch a Zoom call from within Mattermost after the free trial has ended, again I get the message:

We could not verify your Mattermost account in Zoom. Please ensure that your Mattermost email address matches your Zoom email address.


I am facing the issue with zoom plugin in mattermost.

Do anyone have an idea of what is causing the issue here.

Thanks in advance.