[Solved] Failing to update the bundle ID on the iOS app


I have been searching a way to change the bundle ID for the iOS app. I have followed the steps on Build the iOS mobile app to build the app.
When I follow and build the app, though, it appears that the bundle ID reverts to com.mattermost.rnbeta and similar IDs for the different targets, making the app ID different than what I want it to be.
I have confirmed that the App name and App Icon, which I am also changing per the Mattermost Trademark policy, has changed when building the app, but the app, when installing, updates the app with the com.mattermost.rnbeta ID.

Is there anything else I have to setup for installing with a different bundle ID?

Hi Rikum,

Thank you for reaching out, and welcome to the Mattermost peer-to-peer forums!

Let’s navigate through this together. From the description of your issue, it seems like you’re correctly following the steps mentioned in the guide and making the appropriate adjustments. However, the bundle ID isn’t reflecting your changes.

While you’ve already adjusted the App Icon and App Name as per Mattermost’s Trademark policy, you might be missing a step in code itself.

In addition to updating the bundle ID in Xcode, you should also update it in the Info.plist file of the project. You’ll find this file in the <ProjectName>/ios/<ProjectName>/Info.plist path. Replace every instance of the existing bundle ID (com.mattermost.rnbeta) with your new bundle ID. Also ensure to change the bundle ID for each of your required targets.

Try this, recompile your application, and see if the issue gets resolved. If not, please feel free to post your responses here. We are committed to helping you get this resolved! Remember, no question is too big or small - We’re in this together!

~Mattermost AI Assistant :robot:

[Disclaimer: This was an AI assisted response powered by Mattermost AI. Were any of the above suggestions inaccurate? Let us know by replying to this comment!]

I have tried the suggestion to modify each Info.plist in ios/Mattermost/, ios/MattermostShare, and ios/NotificationService in addition to modifying the bundle ID in Xcode.

The suggestion did not make any differences. The reason why the suggestion did not work as expected is probably related to the fact that each Info.plist gets updated when building using fastlane. Similarly, the file responsible in modifying the bundle ID in Xcode was also being modified.

While it didn’t solve the problem I am having, it looks like I was using the wrong fastlane/.env settings to build from as I had multiple fastlane/.env files for testing. It is working now, so I will close this thread. Thank you for your support.

Best regards,

1 Like

Hi Rikum,

Thank you for updating us on this matter!

I’m glad to hear that you found a solution and it’s working now. It indeed sounds like using the accurate fastlane/.env settings was the key. Super appreciate you circling back to close the loop on this!