[Solved] GIPHY Integration not working after upgrade

For feature requests, please see: https://mattermost.com/suggestions/.

For troubleshooting questions, please post in the following format:

GIF picker with GIPHY give error loading GIFs

Steps to reproduce
Click on the emoji/gif picker and select gifs

Expected behavior
Display GIFs as before when using Gfycat

Observed behavior
message stating that there was an error loading GIFs

upgraded from 8.1.0 to 8.1.1 following the instructions at upgrade link.

The upgrade went fine as far as I can tell, but the gif picker does not seem to be able to connect to Giphy.

I’ve made sure the gif picker was enabled in the system console integrations section

Here are the only things I can find in the config.json that would pertain to GIFs

        "EnableGifPicker": true,
        "GfycatAPIKey": "2_KtH_W5",
        "GfycatAPISecret": "3wLVZPiswc3DnaiaFoLkDvB4X0IV6CpMkj4tf2inJRsBY6-FnkT08zGmppWFgeof",
        "GiphySdkKey": "",

Should there be a giphy api key/secret in there like there was with gfycat? Is there something I’m missing in the config?


[Solution updated 10/17/23]

Mattermost installations already include a production-ready GIPHY key, and there is no need for admins to make any changes in this regard.

1 Like

Hi John,

I got a giphy sdk key and added it to the mattermost config.json, restarted the server and the gif picker works now.


1 Like

Heyooo! So glad to hear that worked. Thanks so much for following up to let me know, Rick! :slight_smile:

Sorry if this high jack isn’t allowed! But why haven’t mattermost included their own giphy key? I tried to get my key upgraded to a production key and it failed since it didn’t comply with their terms. Is everyone just gonna use a beta key?

[Solution updated 10/17/23]

Mattermost installations already include a production-ready GIPHY key, and there is no need for admins to make any changes in this regard.

You can read more in this recent announcement from our team below. :point_down:t2:

:mega: GFYCAT is going away. What does it mean for Mattermost users?

Let us know if you have any further questions or need assistance with anything else!

We keep Mattermost config in the database. I updated the server to 8.1.3, obtained SDK key from GIPHY and updated SDK key in configurations table in mattermost database. It didnt work. I noticed that after Mattermost restart the value is being overwritten with empty string. Tried multiple times with the same behaviour.

@mayqueeen after upgrading to 8.1.3, is the gif picker not working for you ? This version had a fix that included Giphy as the new gif provider pre-configured and ready for production use out of the box. There shouldn’t need any config changes necessary.

Nope, it doesn’t work.

@mayqueeen When I upgraded to 8.1.1, I had to go to developers.giphy.com to create an app and get a sdk key. Once I got the key, I put it in the config.json under “GiphySdkKey”: “paste sdk giphykey here” option in order for gifs to work. I had to restart the mattermost service after I got the key in the config before the gif picker would work, If I remember correctly. I don’t think there is a giphy key in the selfhosted download that is usable as that option was empty…unless something has changed with later 8.1 versions.

Perhaps, nevermind on my reply…upon re-reading your post, you may have a different issue? Seems like the difference is you have the config in the database, while my config is under the config folder under the mattermost installation folder.

@mayqueeen what version did you upgrade from? Would you be open to creating an issue in our Github repo so we can troubleshoot this? https://github.com/mattermost/mattermost/issues/new

There should be no need to update the Giphy key so this would be a bug if it’s not working so we need to look into what the problem is.

1 Like

I upgraded from 7.8.2. I will open an issue.

1 Like

Our emoji picker is still broken in Mattermost Version: 8.1.2, Database Schema Version: 113. Our install is bundled with gitlab-ce. I don’t see a GiphySdkKey in our /etc/gitlab/mattermost-config.json file, so perhaps that config wasn’t adequately migrated.

edit: correction, i was wrong, the GiphySdkKey did exist, and was set to empty string. Using our own generated key in that config did fix the emoji picker.

1 Like

@mayqueen after more investigation, we did find an issue where the Giphy production key was not being set properly for our team edition versions. This is now fixed and you can expect this to be working in the following upcoming dot releases:

  • v7.8.13
  • v8.1.4
  • v9.0.2
  • v9.1.1

Thanks all for reporting this issue :+1: