[SOLVED] How to Check Currently Installed Mattermost Server Version?

Neither mattermost version nor platform version is working for me.

Just wanted to check if my mattermost server update/upgrade is successful

For additional context, I’m upgrading my mattermost server from 3.7.x (I think) to version 4.0.1

1 Like

Thanks @andrewblue, would the documentation here be useful? There’s an example on how to check the Mattermost server version https://docs.mattermost.com/administration/command-line-tools.html#using-the-cli

You can also check the version by going to

  • Main Menu right of your profile (in top left corner)
  • selecting “About Mattermost”

Following the documentation, when i run sudo ./platform version, I will get the following

[EROR] Failed to ping DB retrying in 10 seconds err=dial tcp: lookup dockerhost on IP-ADDRESS: no such host

Hmm okay, and everything else appears to work on your Mattermost instance? No other errors in the server logs (System Console > Logs)

1 Like

It shows this in the “System Console Server Logs”

[2017/07/20 12:34:25 UTC] [INFO] Current version is 3.7.0 (3.7.3/Wed Mar 22...

and it shows this in the file /logs/mattermost.log (default path)

[2017/07/20 11:46:52 UTC] [INFO] Current version is 4.0.0 (4.0.1/Wed Jul 19...

Inside the System Console Server Logs, I also have plenty of /api/v3/user errors (e.g. id wrong, expired sessions, no invite, etc…)

Oh but i’m unable to use the new Android App to log into the server (it says need server needs to upgrade)

Ok this is sad but i fixed this - I was upgrading the wrong folder.

I had a “test” or development folder and another for production. (Hence the difference in log versions)

Glad you’ve resolved your issue @andrewblue :slight_smile: