[SOLVED] Mattermost Android App (1.8.0) not starting up

I’ve updated the app to 1.8 few days ago and the app now doesn’t start properly.
The splash screen will show, then it displays a:leftwards_arrow_with_hook: “Reload” icon with Refresh under it.

Uninstalling the reinstalling doesn’t help.

Running Android 8.0 on Galaxy Note 8
iOS app runs fine and connects to MM 4.9.0 server

Any ideas?

Is there any way I can download the previous version of the app?

Edit: Tried to post a reply with a pic but my account got restricted.
@amy.blais here is the screenshot

@yanuk Can you help share a screenshot of what you are seeing?

After the splash screen this comes out.


@yanuk Are there any logs you would be able to help gather or are you seeing any errors in logs?

Also, are you able to access the Mattermost server from the mobile web browser?

Hi @amy.blais , I think I’ve figured it out. It might be the secure websockets not connecting (header truncated error)

The issue, somehow connecting to https://mm.mydomain.com:8065 doesn’t seem to work well I needed to do reverse proxy https://mm.mydomain.com (port 443) and proxy it to 8065 in apache to work.

I fixed that and it now seems to connect beautifully on the app.

As additional info, yes I was using the mobile Web version when I couldn’t login the app version. Desktop and mobile browser works.

Changing from port 8065 to 443 externally with reverse proxy on apache was the only thing I’ve changed on my server. Internally the service still runs on 8065

1 Like

Glad to hear you were able to figure it out! Let me know if you encounter any other issues.