[solved] Mattermost not working anymore after deleting dangling images

Hello. I am using an nginx reverse proxy + docker images (db and app).

I needed some place on the server and understood that docker images -f dangling=true would give me a list of images unused by any containers.

I ran docker rmi for some of the oldest images (I am 100% sure all of them were created before I installed mattermost ; there is also a discourse instance running on the server and it still works fine after deleting old images).

At the moment when running curl on the app container IP I get:

$ curl
curl: (7) Failed to connect to port 8000: No route to host


  1. Did deleting the old images affected the mattermost containers ?
  2. How can I check that the mattermost data is still safe in the db container ?
  3. Considering I didn’t change anything in docker-compose.yml

Wait a minute… I start the containers with docker start mattermost-docker_app_1 and not docker-compose

See, kids ? Writing a description of the problem is half of solving it: ]. I feel like an idiot.

@mods feel free to delete the thread if you think it pollutes the forum :).

I am leaving it because I am still interested in answers to 1. and 2.