[SOLVED] Move channel - Unable to find destination team


I try to move a private channel from one team to another but mattermost CLI always tells me that the destination team isn’t found. Of course the target team was created before (also tried all lowercase and different team naming variants) but all I get is the message:

Unable to find destination team ‘DESTINATIONTEAM’

I’m running mattermost from inside a gitlab installation (latest version 10.5.2 and mattermost 4.6.0) and of course read https://docs.mattermost.com/administration/command-line-tools.html#platform-channel-move.

The executed command was:

sudo -u mattermost /opt/gitlab/embedded/bin/mattermost channel move DESTINATIONTEAM ja3epwksairptqufxqdq1fdqhh --config=/path/to/configfile

Any hints on how to accomplish moving channel?

thanks & kind regards


Well - finally I got the solution - the destination team has to be lowercase!
Would be fine to mention this somewhere in the documentation.

kind regards & thanks for your great work!

Thanks for your feedback @christian.ruppel and apologies that the documentation was not clear…

After we’ve discussed as a team, we’ll make the necessary documentation updates to ensure more clarification :slight_smile:

1 Like

Hi @christian.ruppel,

I opened a PR here to add a note that team names should be in lowercase: https://github.com/mattermost/docs/pull/1852

1 Like