Mmctl channel move exposes migration bug

Hi ,

When I did a mmctl channel move, I got an error regarding the port I used when I did the migration. I don’t see the logic in a channel containing migration info down to the port used, as a port can change.

I added this post in the CLI category but the more I think about it the more I think it is a bug.

Any help will be appreciated

What error are you seeing and what Mattermost version are you using?

Hi @amy.blais ,

I am using

Mattermost Server

Version: 7.10.3

Build Number: 7.10.3

Build Date: Wed Jun 14 12:11:06 UTC 2023

Build Hash: 74af1505a69a560085fd609620e3f92123e84536

Build Enterprise Ready: true


Version:	v7.10.4
GitCommit:	e5743a6789cbaa280af91d1064924a159a80f82d
GitTreeState:	"clean"
BuildDate:	2023-06-21T13:53:58Z
GoVersion:	go1.18.1
Compiler:	gc
Platform:	linux/amd64

The thing which I could imagine being a bug is that when I do a channel move

mmctl channel move NewTeam OldTeam:myChannel

and I get": dial tcp ip_address:8065: connect: connection refused

It looks like a bug to me because I can’t imagine why a channel would be need to be concerned with the site URL used in the migration process ?

@mgdelacroix @isacikgoz Would you know if this is a bug?

Seems like a connection issue to me. mmctl seems to be getting an error while authenticating with the server. Did you check if the domain name is correct or not? For instance the connection can be https instead of http, or even something else.

Hi @amy.blais and. @isacikgoz ,

The error was on my part. @isacikgoz made a comment that shed light on the issue. I still had the login credentials from the migration. I didn’t ( but should have) realised that this has to be kept current.

However I did see something that is not quite right in this process.

when I ran the following command

mmctl channel move NewTeam OldTeam:myChannel

I got the message

Error: 1 error occurred:
	* unable to find channel "OldTeam:myChannel"

I then discovered that. the is no record of “OldTeam” , however whereas in the GUI I see the team “OldTeam” owning channels, when I run

mmctl team list

I see that “OldTeam” is in fact listed as “main”.

Nevertheless I ran the command with the “main” and it worked.

Thanks @amy.blais and @isacikgoz for the help. Much appreciated

1 Like