[SOLVED] No notification - occasionally have to refresh to see new messages


No notification - occasionally have to refresh to see new messages. (Probably a WSS issue, can someone advise on how to fix? Is there a config I’ve missed in the migration?)

Steps to reproduce

I started on a LXC container, copied the rootfs of the mattermost container into another LXC host as we were migrating from one host to another (with a different IP). I’ve updated the internal IP address on the container and changed the config.json to reflect the new host (MySQL etc)

Expected behavior

For mattermost to work as expected, people to be online etc.

Observed behavior

Mattermost came up okay once the container started and I can login and see old messages and send messages - however if someone sends a message to anyone else they need to refresh the page in order to see it, and they cannot see anyone online even if they are. I also occasionally have WebRTC errors.

My nginx config is quite simple and looks like:

server {
listen 80;
server_name chat.xx;
return 301 https://$host$request_uri;

server {

listen 443 ssl;
server_name chat.xx;

ssl_certificate           /etc/letsencrypt/live/chat.xx/fullchain.pem;
ssl_certificate_key       /etc/letsencrypt/live/chat.xx/privkey.pem;

ssl on;
ssl_session_timeout 5m;
ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
ssl_prefer_server_ciphers on;
ssl_session_cache shared:SSL:10m;

access_log            /var/log/nginx/chat.ibbchina.com.access.log;
error_log             /var/log/nginx/chat.ibbchina.com..asia.error.log;

location / {
    gzip off;
    proxy_set_header X-Forwarded-Ssl on;
    client_max_body_size 100M;
    proxy_set_header Upgrade $http_upgrade;
    proxy_set_header Connection "upgrade";
    proxy_set_header Host $http_host;
    proxy_set_header X-Real-IP $remote_addr;
    proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
    proxy_set_header X-Forwarded-Proto $scheme;
    proxy_set_header X-Frame-Options SAMEORIGIN;


Okay I fixed it. For anyone else having this issue when we moved it we used a different proxy host. Unfortunately that proxy was running a rather old version of nginx (being on Ubuntu 12.04) and didn’t support the use of websockets.

Upgrading to Ubuntu 14 appears to have fixed the issue.

Thanks @ktechmidas, pleased the issue is fixed for you!