[SOLVED] Outgoing webhooks are not firing from Mattermost UI?


I am testing webhooks and the incoming hooks are working fine but the outgoing hooks are not firing … for example, the following is the config for the outgoing hook. I have Outgoing hooks enabled on the server in System Console -> Integrations. In the channel I type the following message " #hook This is a test " without quotes obviously … in the stream the #hook shows as a link / highlighted… but there is no post to the callback? Could there be something with the nginx config or server or firewall config?

Sample Outgoing Webhook
Outgoing webhook
Content-Type: application/json
Trigger Words: hook
Trigger When: First word matches a trigger word exactly
Token: 4t5qrg51zjdk8g34nqhfksoiwy
Created by keithgallant on Saturday, October 22, 2016
Callback URLs: http://keithgallant.com/work/hook.php

If I Curl to to the Callback URL it responds fine …

curl -i -X POST -d ‘payload={“text”: “# A Header\nThe text below the header.”}’ http://keithgallant.com/work/hook.php
HTTP/1.1 200 OK
Date: Sat, 22 Oct 2016 04:34:55 GMT
Server: Apache
X-Powered-By: PHP/5.5.31
Connection: close
Transfer-Encoding: chunked
Content-Type: text/html

“text”: “This is some response text.”


I have this issue resolved now. There was an issue with the firewall.

Thanks for posting back @keithg, I’ll mark this issue as solved.