[Solved] S3: Invalid request signature

Hey there,

I’m trying to set up S3 for Mattermost and after I stumbled over the issue that the region Frankfurt is not supported I tried again with us-east-1.

Now, authentication seems to basically work, but when I try to upload, for example, a new profile image, the upload fails and I see this error in my log:

[2016/05/18 08:42:42 UTC] [EROR] /api/v3/users/811hfkq8ntyd5r8wgrfwkxi3qh/image:WriteFile code=500 rid=edbd9ym9ktyn8eq9sf6jsnnf1o uid=811hfkq8ntyd5r8wgrfwkxi3qh ip= Encountered an error writing to S3 [details: The request signature we calculated does not match the signature you provided. Check your key and signing method.]

Anyone had that problem or knows how to debug / solve it?

This seems to be related to a half-propagated configuration, probably caused by a migration bug as mentioned here [Sovled] System Console: configuration times out while saving.

At least it never occurred after I upgraded to 3.0.2 and started with a fresh database.