Help wanted. Unable to write the file using wasabi S3 Object Storage

Two days ago it works, but now always get error (test is ok), anyone can help me? Thanks.
OS: Ubuntu 22
mattermost version
Version: 9.7.3

tail -f logs/mattermost.log:
{“timestamp”:“2024-05-05 13:15:09.721 +08:00”,“level”:“error”,“msg”:“Unable to write the file.”,“caller”:“web/context.go:115”,“path”:“/api/v4/files”,“request_id”:“mnt8s4gknbnm3x76t7qbap8sho”,“ip_addr”:“”,“user_id”:“3y46f3fhbpnr8yqfn8kcrrnpfe”,“method”:“POST”,“err_where”:“WriteFile”,“http_code”:500,“error”:“WriteFile: Unable to write the file., unable write the data in the file data/20240505/teams/noteam/channels/oz78drjw1bbt7dgic6ntaaywwe/users/3y46f3fhbpnr8yqfn8kcrrnpfe/1ftoonb1a7dfbnr4qtrtxh1y1c/rn_image_picker_lib_temp_3edaf7f6-3a6a-47a8-a29c-944072939dea.png: The AWS Access Key Id you provided does not exist in our records.”}

soveld by sudo apt remove --purge mattermost and reinstall.

I have the same problem, tarball install Wasabi S3 Storage. Until 2 days ago everything worked smoothly for over 1.5 years. The error is:

Unable to write the file., unable write the data in the file 20240505/teams/noteam/channels/oyee43whatgj7m4qmdoni7yyhh/users/1grwc17gdt8b8fimz7c47su4fy/ai7antpjh3dw8ebxjy7nojk49w/X.X: Value for x-amz-checksum-crc32c header is invalid.

Please advise and thank you.

I solved this problem by pure reinstall and reboot.

I’ve move storage to DigitalOcean and it solve the prob some how.
Rclone will do the job.