[SOLVED] Self-signed certificate works on iOS but not Android (or vice versa)

I have my mattermost server 3.9.0 installed on Ubuntu 16.04 LTS. I am using a self-signed certificate and NGINX. I can connect to the server from an ios app on my iPhone. However, I can not connect to it on my Android phone using the Android App from the Play Store. I can, however, connect to the server from the web browser on my Android phone. I have looked up solutions, but they don’t seem to work. My boss says that I need to switch to Apache2 instead of NGINX, but I should be able to get it working using NGINX. Anybody run into this issue and knows a fix? Thanks!

@jrichards Just to clarify, did you download the “Mattermost” or the “Mattermost 2017 - Beta” app?

I tried both of them.

Hi @jrichards

Basically the problem here is the self-sign certificates at least on the Mattermost 2017 -Beta app mentioned by @jasonblais they are not supported at this time and I don’t really have an ETA but you can always use a free SSL certificate from Let’s Encrypt and that should solve your problem

Ok, but using the self-signed certificate works on my iPhone app, just not the Android app. I’m sure there is a reason for it, I’m just not sure what that is. I would like to use the Let’s Encrypt, but you need to have an actual domain name. I’ve visited all of the “free domain name” websites, and they all just seem a bit sketchy to me. Can I just register a domain name with GoDaddy and use that for the Let’s Encrypt certificate?

As long as you have a valid domain name you can use Lets Encrypt, so yes by registering a domain in GoDaddy, assign the IP of you machine to it, you’ll be able to create a lets encrypt certificate.

And it looks like you are talking about the apps that are in the stores right now, not the new beta apps… and in that case yes, the IOS app can connect to a self certificate issued server and the android one can’t, that is a known issue that won’t be resolved for those apps as they are now in maintenance mode, and hopefully the same issue will be resolved soon with the new apps.


At least it’s a known issue and not just me. That’s good to know. Do you think that it would be possible to connect Mattermost to a Wordpress domain? I just started looking into it.

Hi @jrichards,

Thanks for your feedback,

You can take a look at Zapier’s guide for integrating WordPress and Mattermost here

Hope this helps!

So we’re actually having the exact opposite issue, where our self-signed cert works with the Android app, but NOT the iOS app. Is there a place to see the road map of when they plan to resolve this issue?

Hi @jibberish,

Thanks for your feedback,

Are you using the classic app or beta app?

There appear to be three apps in the Google play store. Regular, classic and beta. My team is all using the Regular one.

I’ll have to confirm which version the sole iOS guy is using, but I’m confident is the regular version as well.

Hi @jibberish,

Thanks for your feedback,

The two versions that should be in the play / app store are “beta” and “classic”. There might be a “beta 2017” version but that is old and is going to be removed soon. The “beta” version is the new app in react native.

Hope this helps?

Right now, (3) versions show up for me in the Google Play store (https://goo.gl/photos/77rmnZ5Y7Y8Zzsue6), but we’re using the Android version 1.0.1 (build 41) referred to simply as “Mattermost” in the Play store.

I don’t know what iOS version our teammate is using, but I’ll reply as soon as I hear back from him.

Teammate is using the same version on iOS

Thanks for the feedback @jibberish,

Ah, ok - that is an old version and can be deleted from your device. You can install the “Mattermost Classic” version instead.

If you’d like to test out new features before they’re released you can sign up for the beta program here: https://github.com/mattermost/mattermost-mobile/blob/master/README.md#testing

Does this help?