[SOLVED] Some devices unable to connect to Mattermost service

For feature requests, please see: http://www.mattermost.org/feature-requests/.

For troubleshooting questions, please post in the following format:


On a single network, some mobile devices can connect to our Mattermost service, others cannot

Steps to reproduce

Mattermost 4.1.0. This might be hard to reproduce, since the problem could be something in our local network.

Expected behavior

Clients should be able to connect from both internal and external networks, consistently.

Observed behavior

We’re using a split DNS configuration; the hostname for our Mattermost service resolves, on our internal network, directly to the VM running Mattermost. On external networks, it resolves to a Brocade Traffic Manager appliance which then passes the request on to the Mattermost VM.

Clients on public networks connect fine. Clients on our wired internal network seem to work fine also. The problem is with mobile clients attached to our “internal” wireless network. Some work and some don’t, with no discernible pattern.

For example:

MacBook Pro on “internal wireless” network: Works perfectly, for both Desktop client and Safari
iPhone SE on “internal wireless” network: Works perfectly using App Store client
iPad Pro on “internal wireless” network: Fails to connect, using either App Store client or Safari
Same iPad Pro connected to “eduroam” network (treated as external): Works perfectly
Colleague’s iPhone on “internal wireless” network: Fails to connect

If this were a straightforward firewall issue, I’d expect no clients to ever work on the internal wireless network.

This may well not be an issue with Mattermost, but if anyone has any ideas I’d like to hear them!

Hello @tcutts ,

I wonder if this is a cached DNS issue since you are running split DNS inside of your org. On one of the devices that’s having the issue can you try turning on Airplane mode, waiting 5 seconds, turning off airplane mode and launch MM after the device reconnects to the internal wifi network? I’ve seen iOS devices act really stubborn with DNS and in the past I’ve cleared DNS with cycling airplane mode.



Additionally to what sousapro have said, have you tried checking the routing to your mattermost from the devices with the issue?

You have this tool https://itunes.apple.com/us/app/inettools-ping-dns-traceroute-port-scan-tool/id561659975?mt=8 for iphone and ipad, so you could run the trace route option and see what route its taking.

I discovered the problem. It’s whether the system was configured to use our squid web proxy or not. Web Socket doesn’t work with squid, hence problems. I’ll look into making sure iOS devices have exceptions put in their profiles.


Thanks for the feedback @tcutts, glad you worked it out :slight_smile: