[SOLVED] Some users can not initiate Direct Message (DM)


some users (2) not not create a direct message conversation to another user but they can chat in an DM that has been created by another user.

Steps to reproduce

I do not know how to recreate by others.
we are using MM Version: 3.5.0 (3.5.1) Database: postgres
We imported users etc from Slack.
user 1: chromebook: chrome / Firefox and Android
user 2: windows firefox, iphone
behaviour is on the browser and on the app.
users can search for other users in the field at the direct message part.
When clicking on the button to start DM with other user. nothing happens.
When another user starts the DM, then messaging to each other in the DM is no problem.

when user 1 is going to pre-release.mattermost.com this strange behavior is not present in the browsers.

Expected behavior

click on the button and are able to send DM to a user

Observed behavior

no error message. .Clicking the button does not give responce in app/web

Please advice what can be of this error for some of the users,
or what to do to provide more information to resolve this strange behavior.

thanks so much!

Hey @edzob, there is a bug where users imported from Slack cannot start direct messages.

A fix for it was submitted and should be available in Mattermost 3.6, to be released on January 16th: https://github.com/mattermost/platform/pull/4933

1 Like

This is so cool the hear. Thanks very much for the reply.

Looks like they fixed this in the update but for those of you that haven’t had chance to install the update I’ve done the following:

Ends up this happens because there is no role set for the user in the DB for slack imported users. I was able to fix it with the following command in Postgres:

update users set roles = ‘system_user’ where email != ‘admin@yourdomain.com’;

Make sure to update admin@yourdomain.com with the correct email for your system admin account.



We are using omnibus (gilab/mattermost), and the update is not available yet. But I found out, that if you change the role back and forth between e.g. Team Admin and Member, apparently the role gets set properly. Depending on the number of users you have, this might be an easy solution.


We had the same issue … If its not to many users … you can go to system console, make those users system admin or somthing else and then immedeately make them member again. This solved the problem in all our cases…