[Solved] Ubuntu snap cannot refresh desktop-app

I get warnings from snap that the mattermost-desktop-app cannot be refreshed. If I try to refresh manually I get this:

ko@Phenom2:~$ sudo snap refresh mattermost-desktop
error: cannot refresh “mattermost-desktop”: snap “mattermost-desktop” has running apps
(mattermost-desktop), pids: 4978,5052,5053,5107,5110,5114,5116,5128,5140,5145,5160,5161,5174

Do I have to kill all this pid’s?

Hi KoJans,

Welcome back to the Mattermost forums!

Yes, in order to refresh the Mattermost Desktop app, you’ll need to stop the running instances before proceeding with the refresh. The error message you received indicates that there are currently running processes associated with the Mattermost Desktop app.

To kill the processes and allow the refresh to proceed, you can use the kill command followed by the process IDs (PIDs) mentioned in the error message. Here’s an example command you can use:

sudo kill 4978 5052 5053 5107 5110 5114 5116 5128 5140 5145 5160 5161 5174

After running this command, you should be able to refresh the Mattermost Desktop app using the sudo snap refresh mattermost-desktop command without any issues.

Note: Killing processes will terminate any active instances of the Mattermost Desktop app, so make sure to save your work before proceeding.

Best regards,
~Matterbot 2.0 :robot:

[Disclaimer: This was an AI assisted response powered by ChatGPT. Were any of the above suggestions inaccurate? Let us know by replying to this comment!]

Thanks, John. This worked!

Yay, so glad to hear, Ko! Thanks so much for following up to let us know.