Windows Desktop App Crashing on Startup

Windows Desktop App 5.2.1 Crashing on Startup

Steps to reproduce
I updated the app (automatically from within Mattermost) and on the next launch, it crashed and won’t launch any more. Uninstalling and re-installing didn’t help.

Expected behavior
Mattermost Desktop should open and be usable.

Observed behavior
Mattermost Desktop crashes on startup, rendering it unusable.

See the following error screenshot:

Screenshot 2022-11-17 085311

1 Like

Hi Oromis and welcome to the Mattermost forums!

Can you please try to rename your Mattermost appdata directory to see if creating a new one helps?
To do that, stop the client, navigate to %APPDATA% on you system (usually c:\users\<username>\appdata\roaming) and rename the folder Mattermost in there to Mattermost.old f.ex.
Then start the client again and see if that helped. You will lose your configured profile and settings, but I assume that one of the locally stored states, caches or config entries is invalid and causes this problem.

This would have helped, but it’s enough to just delete the downloads.json file inside the %appdata%\mattermost folder and then try to start the application again.

Ticket for that: [MM-48483] - Mattermost

1 Like

Hi Agriesser,

[Windows 11]. Same problem for me. Yesterday I downloaded the update through the Mattermost desktop client and it immediately broke the programme for me with the same error message as in the OP.

Curiously, I downloaded it on a different User account on my computer (the Admin account), and there wasn’t a problem. But that wouldn’t pass through to my MyName account, and whenever I uninstalled and reinstalled Mattermost in that account the same problem occured.

Your comment solved my problem (partially, see below). Namely, I went to C:\Users\[MyName]\AppData\Roaming\Mattermost and deleted downloads.json.

Then I launched Mattermost through the Start menu, and it seemed to fix itself.

I don’t understand this at all, but at least it’s fixed now. So I recommend people reading this try that solution. And thank you for that.

However, there is still a problem. In Control Panel ‘Programs & Features’, Mattermost is listed. The program is installed, somewhere. But it’s not in Program Files or Program Files(x86). It’s also not listed in ‘All Apps’. I can only open Mattermost using a Desktop shortcut that happened to be created, and I can’t pin it to Start. So I can open Mattermost but it’s messy. Not good.

Hey ferdob and welcome to the Mattermost forums!

Mattermost desktop apps can be installed in several ways, systemwide or only for specific users. It all depends on the permissions you have and I think the installation you’re seeing in your control panel is the one your admin account installed systemwide. The ones you installed with your user account will probably just be installed below your user profile.
Are multiple users using the same computer or are you just trying to avoid working with administrative permissions and are therefore using two different accounts on your computer?

Hi Agriesser,

Thanks for your reply.

Only one person uses this computer (me). I have a separate Admin account for security reasons, which I don’t use. I use my MyName account day-to-day. I don’t mind installing Mattermost on the MyName account, I do that for most programs. I tried installing it on the Admin account because I first assumed that was the cause of the problem.

OK, so my suggestion then is to uninstall all occurences of the application first and then install a clean version with the user account you’re working with.

If you have troubles removing the installed version for your user account, please search for mattermost.exe below your user profile in explorer f.ex.
On my system, the application is installed in C:\Users\MyName\AppData\Local\Programs\mattermost-desktop\Mattermost.exe, so in order to remove it you just need to delete the mattermost-desktop folder if it’s still there after you uninstalled everything else.