[SOLVED] Unable to delete messages


Whenever using the delete option on a message not belonging to the current user, it does not work.

Steps to reproduce

Try to delete a message from another user, the option to delete it is proposed, the confirm modal appears, but no action is done.
The user trying the action is an administrator of the team/channel

Expected behavior

Really doing the delete action, or at least, do not propose it if not possible/intended to work this way.

Observed behavior

No error message and no deletion of the message.

Hi @raphael.cazorla,

Thanks for your feedback,

Could you share the version of Mattermost you have installed?

Hi @lindy65,

Of course, here is the version linked to the bug: CE 4.0.1

Hi @raphael.cazorla,

Thanks for the feedback,

By “CE 4.0.1” do you mean Team Edition? Could you share a screenshot of your “About Mattermost” screen please? (3-bar main menu > About Mattermost)

I have tried on numerous servers running different versions of Mattermost and am not able to repro your issue. As a team / channel admin, I am able to delete someone else’s message (behaves as expected).

Yep, sorry, I’m used to general wording of tools.
So yes, Team Edition, 4.0.1.

For the record, I noticed that in the system logs (/admin_console/logs), I repeatedely had this log:
You do not have the appropriate permissions [details: userId=XXX, permission=delete_others_posts

And I have to add this information:
This happens whenever an admin of the team tries to delete a post from a direct message channel.
The message really disappears after confirming deletion, but it reappears on refresh of channel.
And this error is sent in the logs.

So I guess, normal behavior ?
An admin can’t delete a post in a direct message channel that belongs to a user?

Thanks for the feedback @raphael.cazorla,

Yes, expected behavior on Team Edition.

On enterprise edition, it’s possible to set up more specific permissions via the system console.

Ok, thanks, I close this non-bug topic :wink: