Some users don't appear in the autocomplete box that pops up for @-mentions or search

Some users don’t appear in the autocomplete box that pops up for @-mentions or search.

Steps to reproduce
Server version 7.0.1, various clients. Either:
in the Post area, type @
in the search box, type from:

Expected behavior
All active users should be visible.

Observed behavior
Some users are entirely missing from the autocomplete list - however, if the full username is typed, the @-mention works normally. The same users are still missing after a restart of the server. Interestingly, after clicking on “Members” next to the channel name to bring up the list of members on the right side of the screen, the problem goes away and autocomplete works perfectly within that channel.

Mattermost Version: 7.0.1
Database Schema Version: 85
Database: postgres

Is there a way to solve this?


are you using elasticsearch or bleve for autocomplete searches (you can enable that in the respective sections in system console). If so, try to disable that and see if it fixes your problem. If it does, you might need to reindex ES or bleve and maybe check on regular re-indexing.


1 Like

Hi Alexander,

I appreciate your help.

Thanks to you I was able to solve the problem.

I was using Bleve. Once I purged the index and then rebuilt the index, the problem seemed to go away.

Thank you.