Testing Debian Jessie deployment instructions


tried to install this on one single machine based on this:

Database server is working but step 7 in setting up mattermost server (using in
config.json) causing neither or:

di@cubietruck:/opt/mattermost/bin$ sudo ./platform
./platform: 1: ./platform: ELF: not found
./platform: 1: ./platform: Syntax error: word unexpected (expecting “)”)

di@cubietruck:/opt/mattermost/bin$ ./platform
-bash: ./platform: cannot execute binary file: Exec format error

Same for Ubuntu and for Debian, tried both!
(postgresql 9.4 at Debian, 9.3 at Ubuntu)

Any idea??

Thank you!

…doesn’t run under arm architecture.

Any idea will this happen soon?

hi @AndiHD, could you share more about when you’d want to run a server under ARM?

Haven’t heard about this in the feature idea forum and no near term plans.

Hi @it33,

I used a Cubietruck (more or less a raspberry with SATA) and tried to use this as my own single server. Just for evaluation. Didn’t had in mind that this is not a x64 platform as I’m testing a lot of things on it.

Buy the way…zulip is running very good on it :wink:

I’m just testing mattermost on AWS but don’t get it to run…fourth time installing it but always get the feedback “No Docker image specified in either Dockerfile or Dockerrun.aws.json. Abort deployment.”

Using dockerrun.aws.json V1.3

Thanks @AndiHD, if you just want to try out Mattermost on AWS, maybe spin up a pre-installed Amazon AMI?