Turn off file downloads on mobile devices


We use the Mattermost system and we are happy with it. But I want to turn off file downloading on mobile devices. It doesn’t work. What could be the reason? I changed the value in the configuration file as below. It didn’t work. Please help me.

My Mattermost Versiyon : 7.7.1

“EnableMobileDownload”: false,

7.7.1 is pretty old. I’d strongly recommend upgrading to a newer version. Release Lifecycle — Mattermost documentation

Did you restart the Mattermost service after changing the config? Anything in the logs or journalctl output that looks relevant?

Thank you very much for your reply. I updated the system to 9.5.1. The setting I mentioned is as follows. Unfortunately, we can still download files from mobile devices.
Please help me. I don’t want to download files from mobile devices. Or is there a different way?

Are users using the mobile app, or a browser? We cannot block downloads from the browser.

We are use Mobile App.

What version of the app are you using? I’d try upgrading at least one instance in case you’ve encountered a bug that’s already been fixed.

Next, try using mmctl config show to verify that the parameter is actually set in the running instance… it’s possible that it’s actually using a different config source, like environment variables, than you think it is.

I’d also suggest enabling debug logging, tailing out the Mattermost log file, do a download, and watch the logs for anything that might be relevant.

1 Like