Unable to Configure Server


Trying to install mattermost on CentOS Linux 7 (Core), Kernal Linux 3.10.0-514.6.2.el7.x86_64.

I’ve followed the instructions on this page (https://docs.mattermost.com/install/install-rhel-71.html#configuring-mattermost-server) which has worked fine up untill Configuring Mattermost Server. I have tried browsing to the server by IP address, DNS name, with port 80 and 8065 but always get a timeout error. (ERR_CONNECTION_TIMED_OUT)

Everything else in the process has worked and do get html when I curl http://localhost:8065 as well as the ip address and port.

Can anyone point me in the right direction?


If you can reach the server via http://localhost:8065 but not via http://yourdomain.com:8065 that suggests you may have a firewall that is blocking access to port 8065 over public network interfaces, but not the loopback interface used to reach localhost. Please could you check if you have some firewall activated, or iptables rules that are blocking this?

Additionally, could you please check if the Mattermost server is listening on only the loopback interface using sudo netstat -plnt. (You can paste the output of that command here if you need assistance interpreting it).