Unable to create new channel after upgraded from 5.08 to 5.13

Dear supporters,

I have faced following trouble after carried out the upgrade, I would appreciated it if someone can tell me workaround to fix or avoid this.


I have just upgraded Mattermost from 5.08 to 5.13 and have been confirming it,
I have found unable to create “New Channel” after upgraded both of web interface and CLI.

Mattermost Enterprise Edition

Modern communication from behind your firewall.
Mattermost Version: 5.13.1
Database Schema Version: 5.13.0
Database: mysql

Steps to reproduce

  1. Log it in as initial user to Mattermost and then tried creating new channel using plus bottom by “PUBLIC CHANNELS”.
  2. Select “Public” and enter the name of channel to be created and submit it using “Create new channel” bottom, however, screen has not moved to next with displaying “Unable to find the existing channel”.
  3. and I have found no new channel has been created.

Expected behavior

Created new intended channel, both of web interface and CLI.



Hi @nkumada, there might be a setting in the Advanced Permissions section of your system console that you need to edit: https://docs.mattermost.com/deployment/advanced-permissions.html.

Hi Amy.blais,

Thank you for sharing the work around, I have solved it!
I really appreciated.