Unable to npm install mattermost-webapp

node version: 12.16.2 (Tried to install via yum & nvm)
npm version : 6.14.4
Mattermost webapp version : 5.22.0 (downloaded from github)
Environment :centos /redhat 7 (tried on both)

Was following these steps to customise mattermost

  1. Install the Mattermost server by following one of our installation guides
  2. Fork the mattermost-webapp repository
  3. Make your changes
  4. Run make package to create mattermost-webapp.tar.gz
  5. Copy mattermost-webapp-tar.gz to the location Mattermost was installed in Step 1
  6. Remove the existing client folder
  7. Run tar -xvf mattermost-webapp.tar.gz to extract your new customized client folder
  8. Restart your Mattermost server

However i keep having Keep getting enoent : no such file or directory. I tried to installed the missing modules but hit a dead end eventually

My problem looks similar to https://github.com/mattermost/mattermost-server/issues/11767

Additional steps tried: deleting package-lock.json, npm cache clean, rm -rf node_modules

Could it be a space/OS issue? Thank you in advance

I used window os , node 10.13.0 and npm 6.4.1 and managed to npm install

I have also the npm errors… But use Linux.