Update from 7.5.2 to current version

Hello all,

I am relatively new here in the area of Mattermost and wanted to ask whether it makes sense that I do not take the way of UPGRADE for the beginning and set up the system (self-hosted) again?

I haven’t done anything else yet, as this is a relatively new topic for me.

Or would it make sense to upgrade according to the instructions, so to speak as training for the future?

Kind regards

Z. Matthias


upgrading is not difficult, it boils down to stopping the server, copying the new files over the old ones and starting the server, which will then automatically take care of the rest.

Serting up a new system will require to carry over the configuration and migrating users and data (unless you really want to start with a completely fresh install).

Hey Agriesser,
thank you so much for your answer.

So, I decide, that I´ve installed it NEW and deleted the old Version completely. And it’s work fine now.

One question is coming out:
I have installed a NGINX proxy server in front of the Mattermost server and the redirection works perfectly.

However, what do I have to enter under the system console of Mattermost? At least Mattermost asks for this every time I log in as “Administrator”.

Kind regards

Z. Matthias

You mean for the Site URL setting? This should point to the URL your clients are accessing, so the URL which points to your nginx (including the scheme and ports (if non-standard)).

If this is not what you meant, can you share a screenshot of what Mattermost is asking you, please?

Hey Alexander,
yes that is the point, that i meen.

It is possible to say, that i configure it whith localhost, so that no poeple goes directly to this site?

Best regards

Z. Matthias

Sure, but this of course only works if nginx is running on the same server as Mattermost, otherwise a localhost connection is not possible.

In order to make sure Mattermost only listens on the local interface, you will need to change the Listen Address in System Console → Environment → Web Server to (The default value :8065 means that it will listen on all interfaces on the server, therefore nginx could be bypassed).

You need to restart Mattermost for the change to take effect and you can verify that this is working by comparing the outputs of lsof -i :8065 on your Mattermost server before and after the change (you should see *:8065 before and afterwards).

Thank you very much, i understand.

If I do that in this way, i must change on NGINX the IP-Address from Backend, or? So that, NGINX knows and find this instance…

Best regards

Z. Matthias

If nginx is running on the same server, the backed on nginx just needs to be set to localhost:8065, that should be it.

Hey Alexander,
thank you very much, it was very helpful and i can changed it on my system.
And YES, on my Server with Mattermost is NGINX running. Have a nice weekend and /or Sunday afternoon /evening.
Best regards

Z. Matthias

Awesome, thanks for the confirmation :slight_smile: I’ll mark this as resolved now.