Upgraded to v5.6, Get an error when attaching files

Just upgraded to v5.6. Now when we attach a file or image to a post, the screen goes blank and the following error is logged:

2018-12-16T17:13:40.107-0600 error web/context.go:60 msg: Uncaught TypeError: Cannot read property ‘toFixed’ of undefined row: 36 col: 79222 stack: TypeError: Cannot read property ‘toFixed’ of undefined url: https://host.example.com/static/main.495bc49800ee9aa7d2f3.js {“path”: “/api/v4/logs”, “request_id”: “1snjgfwwx3yq9xhppx6eaqrhac”, “ip_addr”: “”, “user_id”: “6w9cdk4adprj3fjprgtzesbt7h”, “method”: “POST”, “err_where”: “client”, “http_code”: 0, “err_details”: “”}

The only way to recover is to go to the view menu and select reload. This happens in both the desktop (v4.2) and web clients. Oddly enough, the android client works. Could this be related to the new progress bar for file uploads?

I’ve rolled back to v5.5 for now. I’ve got 197 users who would are already grumpy with me for moving from Openfire to Mattermost :smiley: Mostly due to notifications difference at the moment. I’m willing to try the upgrade again and help troubleshoot any way I can. By the way, I’m on the team edition if that helps. I did the upgrade from 5.5 to 5.6 skipping 5.5.1.

Thanks for the report! We’ll take a look and try reproduce - if we’re unable to, we’ll touch base with a few questions to help narrow down the cause :slight_smile:

Hi, @ChristopherBrand

I tried to reproduce it on my end by upgrading my 5.5 to 5.6 but did not run into any issues when uploading image / files. Does it happen to any type of files / images (eg. jpg / png)?

For the web client, is the problem reproducible on Incognito / private mode of the browser? Does the problem occur again after you fixed it by reloading the client?

Hi @dannymohammad, I didn’t do an exhaustive test on different file types. I tried a text file and an excel file. Both showed the same problem. One thing I forgot to mention, is that I tried it with Chrome and the desktop client, both got the white screen and had to reload to recover. Even after reloading the issue persisted. I even cleared the cache and reloaded and still had the same issue. I also uninstalled and reinstalled the desktop 4.2 client to see if that helped which It didn’t.

Weirdly enough, I believe it worked okay with Microsoft’s Edge browser. I didn’t have time to do a lot of testing before I rolled back to 5.5. I didn’t get a chance to try it with Firefox.

1 Like

Thanks @ChristopherBrand for the report, and @dannymohammad for trying to reproduce. I tried as well but wasn’t able to.

There is another report of a similar issue too: https://github.com/mattermost/mattermost-server/issues/10011#issuecomment-447902237

I’ve posted to our team about it to see if they can pinpoint a potential cause based on the error. I’ll follow up with questions and/or next steps for fixing the issue.

1 Like

Thanks @jasonblais and @dannymohammad :smiley:

1 Like

Hi @ChristopherBrand,

Although no-one on our team was able to reproduce the issue, our devs have included some extra checks for file uploads and the fix will be released in v5.6.1 later today.

Please let us know whether you still experience any issues once v5.6.1 is released and after you’ve upgraded.


Hi @lindy65, Strange that you weren’t able to reproduce the issue. Could be something specific to our setup. I saw that 5.6.1 was released yesterday. I’ll upgrade either today after work or tomorrow when I can do it without interrupting the users.

I’ll definitely post back with the results. Hopefully, I won’t see the issue, but if I do, I’ll do more testing while I have it installed to see if I can figure out a cause.

Thank you all for your help! :grinning:


I’ve upgraded to 5.6.1 and everything seems to be good. No issues attaching files to messages. :+1: Thank you, I appreciate the help.


Thank you @ChristopherBrand for letting us know. Glad the issue is fixed :slight_smile:

1 Like