Upgrading Mattermost 7.1 Docker version

I recently started getting msgs on the mobile app that the server is out of date. I’m currently running version 7.1 running via docker. I tried upgrading mattermost 7.1 docker install to 7.9 but didn’t succeed. The version is still 7.1 even after changing the env.example file

I tried following all steps here but still wasn’t able to upgrade my install - Upgrading MM Docker Install - #4 by greatscott

Did this first

docker-compose pull

Changed Env.example file to this

MATTERMOST_IMAGE=mattermost-team-edition  (tried changing this to enterprise edition too with no avail)
MATTERMOST_IMAGE_TAG=7.8 (tested different version numbers here)

Then I did

sudo docker-compose -f docker-compose.yml -f docker-compose.without-nginx.yml down && sudo docker-compose -f docker-compose.yml -f docker-compose.without-nginx.yml up -d

Expected behavior
This should’ve updated me to version 7.8 but its still on version 7.1

root@ubuntu-4gb-fsn1-1:~/docker# sudo docker images
REPOSITORY                                 TAG         IMAGE ID       CREATED         SIZE
postgres                                   13-alpine   1636db173231   5 weeks ago     232MB
mattermost/mattermost-enterprise-edition   7.1         20ae43758ae7   4 months ago    616MB
mattermost/mattermost-preview              latest      c58a56001918   13 months ago   1.27GB
postgres                                   <none>      ed8ed2786948   13 months ago   213MB
mattermost/mattermost-enterprise-edition   <none>      413e96b0bfc4   14 months ago   531MB
certbot/certbot                            latest      73530438e96c   14 months ago   115MB

Can anyone help me on this?

Hi sagar,

Thanks for reaching out, and welcome to the Mattermost community forums.

I’m sorry to hear that you’re having trouble upgrading your Mattermost Docker installation. Let’s try to troubleshoot the issue together. Here are a few steps we can take:

  1. Make sure you have the latest version of the Docker Compose file. You can get the latest version from the Mattermost GitHub repository: docker-compose.yml
  2. Before running the upgrade command, ensure that you are in the correct directory where your docker-compose.yml file is located.
  3. Double-check that you’ve made the changes to the docker-compose.yml file correctly. In your case, you should set the MATTERMOST_IMAGE_TAG to the desired version, such as 7.8. Confirm that you saved the file after making the changes.
  4. Run the following command to perform the upgrade:
sudo docker-compose -f docker-compose.yml -f docker-compose.without-nginx.yml pull
sudo docker-compose -f docker-compose.yml -f docker-compose.without-nginx.yml up -d

Ensure that the commands are executed in the same directory where your docker-compose.yml file is located. This will pull the latest image and recreate the containers.

  1. After the upgrade process completes, you can check the version by running the following command:
sudo docker exec -it mattermost app version

Make sure the version displayed matches the one you intended to upgrade to.

If you’re still experiencing issues after following these steps, please let me know, and I’ll do my best to assist you further.

Best regards,
~Matterbot 2.0 :robot:

[Disclaimer: This is a beta AI assisted response powered by ChatGPT. Were any of the above suggestions inaccurate? Let us know by replying to this comment!]