Weird login page with no login button, menu, or anything


I’ve upgraded Gitlab install from source to omnibus. Everything works fine, except for Mattermost integration. I can enter the mattermost website, click on “Click here to sign in.”, and then I get redirected to the page below. There are no errors in the browser or in the files /var/log/gitlab/mattermost/mattermost.log and /var/log/gitlab/nginx/gitlab_mattermost_error.log, but also there are no buttons or menu to do… well… anything. Any idea what is going on? Thank you very much.

Mattermost configuration on gitlab.rb file

Here options set on my gitlab.rb config file:

mattermost[‘enable’] = true
mattermost[‘service_use_ssl’] = true
mattermost[‘sql_driver_name’] = ‘postgres’
mattermost[‘sql_data_source’] = ‘’
mattermost[‘email_enable_sign_up_with_email’] = false
mattermost[‘email_enable_sign_in_with_email’] = false
mattermost_nginx[‘enable’] = true
mattermost_nginx[‘redirect_http_to_https’] = true
mattermost_nginx[‘ssl_certificate’] = ‘cert_file’
mattermost_nginx[‘ssl_certificate_key’] = ‘cert_file’

Gitlab version

Gitlab-ce 8.11.4

What matters most is what version of Mattermost you upgraded FROM, that is, what version of Gitlab Omnibus you were updating from?

It’s possible that your gitlab omnibus package’s database migrations for the Mattermost database failed.

If you have no important history (your system isnt really live and in production yet) you can get back online by deleting and re-creating the mattermost database, which is a postgres database, I believe.

In a real production environment that would be a “disaster” for most companies, though, so you may need to manually run some migration scripts to get your database schema migrated.


Thanks for your reply.

I migrated from Gitlab 8.10 (source) to 8.11 (omnibus). Gitlab data is very important, but I don’t mind loosing Mattermost content at this point.

I’m gonna try this suggestion, dropping the database manually and recreating it using gitlab-ctl reconfigure.

Well, I tried to recreate the database and it didn’t work.

What worked for me was to manually configure the options below on gitlab.rb. I’m using both gitlab and mattermost databases on a different server, could that be the problem?

mattermost['gitlab_enable'] = true
mattermost['gitlab_id'] = "<secret>"
mattermost['gitlab_secret'] = "<secret>"
mattermost['gitlab_auth_endpoint'] = "<secret>"
mattermost['gitlab_token_endpoint'] = "<secret>"
mattermost['gitlab_user_api_endpoint'] = "<secret>"