Wiko with Android 7.0 "Cannot connect to the server"

I’m trying to connect to my server with an Android phone and I’m running into this error:

Cannot connect to the server. Please check your server URL and internet connection.

I’ve followed the instructions for Troubleshooting Mobile Applications in the docs, but couldn’t fix it yet.

Some details:

  • The app can connect to https://demo.mattermost.com as expected
  • The device that cannot connect is a Wiko Harry with Android 7.0
  • Other Android devices (Samsung Galaxy J3 with Android 5.1.1) can log in as expected, therefore the server seems to have SSL set up fine (with Let’s Encrypt)
  • No errors in the system logs (logging level ERROR)

How can I debug this further?
Thank you!

Has you issue solved? i am facing the same problem but with samsung Device

It wasn’t solved by any particular action, but after a couple months, login was working again on the troublesome device.

My guess is that there was some issue with DNS cache on the device (or other cache? not sure), since that device attempted to connect before I had set up the SSL certificate.

In the meantime, I asked the user to use the Mattermost web app instead: log into the server via the browser, and “add to the home screen”. It’s far from optimal, but it did the trick until login started working again.

1 Like