2 Issues / Questions that i cant find any solutions for

Hey there Mattermost Community!

I hope im right here, first of all im absolutely in love with Mattermost and the fact that you get such a feature rich self-hosted environment for free!

We recently switched from Slack to MM and we are more than happy! :smiley:

I’ve setup Mattermost-Omnibus on a Ubuntu 22.04 Bare-Metal server.

After installation i went to /opt/mattermost/config and i noticed there is no config.cfg in there, just 2 files called cloud_defaults.json and config.defaults.json my question for this is, where is my actual config.cfg? :sweat_smile:

And my other question is, In the System Console under Workspace Optimization it says there is an Update available (Platform Release v8.0.0), i then followed the guide to updating mattermost-omnibus and ran apt update && apt upgrade and restated the server, but it didnt seem to update anything. why is that?
It made me very confused, espacially the config part.

Thanks for your reading time!

1 Like

Hi Ellie and welcome to the Mattermost forums!

Omnibus does have the config file in the database, you can edit it using the command mmctl --local config edit from the command line.
Unfortunately, the omnibus relases are a bit delayed compared to the tarball releases, so you’re not doing anything wrong here, it’s just that the 8.0 version has not been packaged as of yet as it seems, so please try again in a day or two, it should be available then.

I see! Alright!

Thanks for the quick reply! :smiley:

If its okay to also ask here, i wanted to delete an user-account, is this not possible with omnibus?

This command here from the guide mmctl user delete username throws out
Error: cannot read user credentials, maybe you need to use login first: stat /root/.config/mmctl/config: no such file or directory does not seem to work.

I’ve checked the API but also havent found any call there to delete someone (I am aware that deleting is not recommended.)

Other commands with mmctl work tough, so it cant be an auth issue i guess?

EnableLocalMode is also set to true.

After trying a while i seem to have found a solution, mmctl --local user delete name worked!

No further questions! :slight_smile: this can be closed if thats applied here

I’d prefer new topics for new issues in the future :slight_smile:

You need to use the --local flag for mmctl everytime you run it in order to use the local socket based authentication so you do not need to login with a username and password to Mattermost.
For the deletion of users you might stumble upon another hurdle. I think by default, deletion of users via the API is forbidden, but you can change that:

# mmctl --local config get ServiceSettings.EnableAPIUserDeletion

Use the set command to change the value to true if it returns false for you.

1 Like