App Mac 5.4 (post update) impossible to switch channel

Hi !
I’m sending this message after first reseach, but it seems I’m in a dead end.

This morning, I’ve upgraded my app of Mattermost to 5.3.1 to 5.4 (Mac OS 13.4.1, Macbook Air M1 2020).
Then I wasn’t able to switch channel on the client.

On my reseach, I’ve follow the troubleshooting mattermost page, then I’ve logged in another server without any issue, and I tried to join my team with the browser mattermost version without any issue.

I also tried to downgrade my app, but since I’ve the same issue on 5.3.1 and 5.4 rc1.

On my app, on channel switching, I’ve this message display, then I can do anything, I have to quit the app and re-open on the mail channel.

Message displayed (in french)

Équipe introuvable
L’équipe que vous avez demandée est privée ou n’existe pas. Veuillez contacter un administrateur pour recevoir une invitation.

I’ve check on the log of the application on my mac and found this :

[2023-06-22 11:57:46.790] [debug] [DownloadsManager] init { 'this.json': {}, validatedJSON: {} }
[2023-06-22 11:57:46.793] [debug] [DownloadsManager] saveAll
[2023-06-22 11:57:46.794] [debug] [MainWindow] Can't send update-downloads-dropdown, will retry
[2023-06-22 11:57:46.794] [debug] [DownloadsManager] checkForDeletedFiles
[2023-06-22 11:57:46.813] [error] Logger Log level set to: info
[2023-06-22 11:57:46.821] [warn]  [App.Initialize] Current working directory is /, changing into /Applications/
[2023-06-22 11:57:46.915] [info]  [App.Initialize] Autoupgrade disabled: false
[2023-06-22 11:57:46.949] [info]  [ServerDropdownView] init
[2023-06-22 11:57:46.954] [info]  [i18nManager] Set new language fr
[2023-06-22 11:57:47.355] [error] [serverAPI] Error parsing server data from ***myserver****/aows/api/v4/config/client?format=old
[2023-06-22 11:57:47.355] [warn]  [App.Utils] Could not get server info for AOWS Error: Error parsing server data from ***myserver***/aows/api/v4/config/client?format=old
    at IncomingMessage.<anonymous> (/Applications/
    at IncomingMessage.emit (node:events:513:28)
    at endReadableNT (node:internal/streams/readable:1359:12)
    at process.processTicksAndRejections (node:internal/process/task_queues:82:21)

Does anybody has the same issue ? Or could have an idea about how to resolve this or find how to resolve this ?

Thank you for your help

Feel free to open a new issue at Issues · mattermost/desktop · GitHub.

Hi Anne-Sophie!

This message is especially interesting:

The /aows here is most likely the problem. Is your Mattermost installation configured to use a subfolder on your server, like What is the URL you can reach the Mattermost login at? Is that or

The URL it’s trying to access here is necessary for the client to configure itself, so you can manually try to validate it using the following command (I ran this command against Mattermost’s community server, just put your real URL there, ideally exactly the one out of the error message above):

$ curl -s | jq .
  "AboutLink": "",
  "AndroidAppDownloadLink": "",
  "AndroidLatestVersion": "",
  "AndroidMinVersion": "",
  "AppDownloadLink": "",
  "AsymmetricSigningPublicKey": "MFkwEwYHKoZIzj0CAQYIKoZIzj0DAQcDQgAEAxVH0LufA1VFQv3Bp5mgckEsZOvEN/VNW3d3sb6Vf3ALO7NGhehajX58st2Ic+xvmBEDnSnXkq74ZVbyAjUQiQ==",
  "BuildDate": "Fri Jun 23 19:15:13 UTC 2023",
  "BuildEnterpriseReady": "true",
  "BuildHash": "936e388aacf0c53ce77342a21de48fbad270d3cc",
  "BuildHashEnterprise": "373a9ec0d566fa4ade017acf4f7f7ca440adb1d1",
  "BuildNumber": "master",
  "CWSURL": "",
  "CustomBrandText": "",

If you can get a JSON struct back like the one in my example, then you should be good to go. Could you compare it to the one from the community server or post the anonymized version here so I can have a look at possible reasons for the parsing problems?

Hi !

You’re completely right, I’ve resolved my issue following an advice : to recreate the serveur of my mattermost on this app. I had done this, but the second time I’ve change the server name on my app and it’s working fine now.

following issue on github : [Bug]: · Issue #2768 · mattermost/desktop · GitHub

Thanks for letting us know and for posting the solution!