Mattermost 5.2.2 no window opening on MacOS when starting

Since ~14/12/2022, no window is opening when I start the mattermost desktop app on my Mac (MacOs Big Sur 11.6). I find no way to open a window. My version of Mattermost is 5.2.2.

Screenshot 2022-12-19 at 15.51.57

I have the same issue - currently running MM 5.2.2 and MacOS Ventura 13.1. Nothing I do, including re-installing Mattermost, clearing cache, restarting MacOS has affect. Window is not hidden, etc.

Any help please.

Hi and welcome to the Mattermost forums, you two :slight_smile:

Can you please try to reproduce this problem with the upcoming 5.3.0 build? It’s not officially released yet, but I just want to make sure the issue hasn’t been fixed already. Here are the links to today’s binary releases, please pick the version that works for your system:


I have a similar issue: I “upgraded” from a previous downloaded version of Mattersmost MacOS desktop to 5.2.2 from the App Store. The first time it seemed that the MM window would not appear, like the OP. Actually, a modal window, hidden beneath all my other open apps was there (see screenshot below). I selected the directory that was preselected when I clicked on the button, and the new version imported my previous configuration, all fine and dandy.
However, now every time I restart the application, the same thing happens again, I have to select the directory. The startup time is also pretty long…
Will this issue be fixed in 5.3.0 ?



Thanks for the additional context - that’s interesting.
Can you share the logfiles of the application when it starts?
You can find them in one of the locations mentioned in the documentation (depending on your installation type):

I am not comfortable sharing this log file that contains company-private information with the whole forum community… Is there a way to share it via DM on ?


sure, if you are able to DM me here, please do so or otherwise you can also find me under the same name on the community server.

Thanks for sharing the logs - the only relevant thing my eyes can spot here is:

[2023-01-06 10:39:02.521] [error] MAS: An error occurred importing the existing configuration Error: Attempted to register a second handler for 'request-has-downloads'
    at IpcMainImpl.handle (node:electron/js2c/browser_init:193:325)
    at DownloadsManager.init (/Applications/
    at new DownloadsManager (/Applications/
    at IpcMainImpl.<anonymous> (/Applications/
    at IpcMainImpl.emit (node:events:539:35)
    at updatePaths (/Applications/
    at migrateMacAppStore (/Applications/
    at initialize (/Applications/

Not sure if this is really related to what you’re seeing - let me consult some of the developers.

@Lauriane , @mkochanik : Together with @garz75 we found out that we cannot reproduce the problem using the DMG installation. Is it safe to assume that you two also installed the desktop application out of the appstore and would you be willing to remove this installation and use the DMG install for testing purposes?
You can find the relevant links directly on the GitHub release page, here are the direct links depending on your architecture:


Hi, Thanks for the assistance, and sorry for the slow answer. I did the new installation and it works. best, Lauriane

Awesome, many thanks for the confirmation!

There’s alread a PR for the fix to this which will be incorporated in the next (5.3) release, so as soon as this is released, you should be able to switch back to the AppStore installation:

When do you expect the 5.3 version to be released?

Hi @pohlvault and welcome to the Mattermost forums!

5.3 is expected to be released in about 14 days. 6 weeks (sorry, confused it with another release).

v5.3 release is scheduled for March 16th. You can read more about the desktop app release process here Desktop app release process - Mattermost Handbook.

@pohlvault can you wait until the middle of March? If not, you could use on of the daily builds to access the new version earlier. Here are today’s links, f.ex.:

Links for Feb-04-2023


I had the same issue and needed to re-install to the links you provide @agriesser

Hi @carlosbort and welcome to the Mattermost forums!

Thanks for letting us know, the underlying problem has already been adressed and should be fixed with the 5.3 appstore release, so you could try to switch back then once the new version has been released (unless it’s OK for you to keep using the DMG/non-appstore version).

Hi. I’m having the same issue at my mac. how do I know which of the macOS links I should use?


Hi @fabripessoa and welcome to the Mattermost forums!

The links indicate the processor architecture you’re running. If you own an Apple device with an M1 chip, then you can use the M1 DMG file, if you have an Intel Mac, then you use the x64 DMG, etc.
If you’re unsure, use the universal DMG, it should contain all versions (but is a bit bigger to download).

Here are updated links, btw:

1 Like

hi @agriesser , thanks for your help.

Issue is solved, but at first it would load but when I tried to log in it would not open a login page… tried restarting the computer, restarting the app, nothing worked.

I finally had to delete the server I had (somehow it loaded the one I used with the other version), re enter the info and then I managed to log in and load everything again.

Anyways, It’s working now, I just wanted to share some feedback.

Thanks again for your help.