White screen won't go away after reloading

When I open the Mattermost app on my Mac, it loads briefly and then turns to a blank white screen.

To troubleshoot I have:
-manually reloaded
-manually cleared cache and reloaded
-manually restarted the app
-manually restarted my computer
-updated the app to Electron v18.3.0 (did all above troubleshooting before AND after updating app)
-uninstalled the app and reinstalled

Nothing works. I have notice that it stays loaded in the background if I have another application in the foreground, but once I click on the Mattermost app window it whites out


what client version are you using? 5.1.1 is the latest version available at the moment.
Can you also reproduce this problem when you use the webapp (i.e. log in via your browser to your mattermost installation)?


Hi Alex,

Using version 5.1.1. Website works, app on my phone works. The support team examined the logs and think that the desktop client wasn’t able to authenticate me to the Mattermost server. Clearing cache/reinstall has not worked though.

They want me to clear the local files, then uninstall/reinstall to troubleshoot, however, they haven’t been able to tell me how to do this on a mac. I am unable to locate ay config files or find Mattermost in /library and I think MacOS monterrey has moved or hidden these folders. I sent them some screen recordings and they confirmed the path isn’t there on my mac, but they haven’t gotten back to me yet with a solution. Any thoughts?

Hi Meesh,

Sorry for not replying earlier, the forum didn’t let me…
I did spin up a Monterey VM and installed Mattermost there, the path has been moved (compared to BigSur), but it’s still there.

/Users/username/Library/Application Support/Mattermost

/Users/username/Library/Containers/Mattermost.Desktop/Data/Library/Application Support/Mattermost

In there you will find several “Cache” directories to clear, you can either do that using finder or using rm -r on the terminal app.


Hi Alex! (pt 1 of 2 since only 1 screenshot allowed)

As you can see, no library under me or admin.

(pt 2)

Searching for /library does not show Mattermost listed, even under application support.

Searching for /containers yields no results.

Can you explain the rm -r option in terminal more clearly? I don’t want to accidentally clear everything.

Thank you

Yah, what Apple does here is trying to protect you from doing bad things - so it hides stuff from you although it’s there.

When you’re in the first screen you sent, try to press Cmd-shift-. on your keyboard, this should enable the display of hidden files and folders then (they look lighter than the others, see my screenshot):

Let’s leave the terminal for now, hope we can get it going using Finder.

We’re experiencing similar connection type issues, that result in a white screen.

The issue is not present when using desktop app v5.0.4 - but when we try using v5.1.0 or v5.1.1 - we have intermittent connection issues. Specifically resolution issues with the internal office IP of our Mattermost server.

I noticed that from MM desktop app v5.0.4 to v.5.1.0 there was a big jump in the version of electron being used (14.1>18.0) wondering if anyone else has been experiencing connection issues with v5.1 of the desktop app.

Edit: we’re using the MM desktop client from Windows machines though.

Hi Jeffrey,

welcome to the mattermost forums!
I’m not aware of any broad connection issues with the 5.1 clients on windows, but electron is not responsible for proper name resolution inside your network, so this might be something unrelated and you should check the DNS configuration in your local network (TTL of the records, f.ex., DNS caching, etc.).

I’m not sure if this is really related to what meesh is seeing here, so if you want to talk about that in more detail, please create a new topic and we’ll tackle it there :slight_smile:

Sounds good, thanks :+1:

I was able to fix it finally! I uninstalled Mattermost, then downloaded and reinstalled from the Mattermost website- NOT the app store. It’s been working perfectly ever since!

Interesting, although this should (in theory) not make a difference. Maybe the full reinstallation caused the Caches to be reset and settings to be rewritten, which is good since it worked for you :slight_smile:

I’m not sure about the future updates then though; so you might need to switch back to the Appstore version in the future, but hopefully this problem is permanently solved for you :slight_smile: